SQL 2005 64 bit Memory Options

Posted on 2011-04-26
Last Modified: 2012-05-11
I recently installed SQL 2005 on Windows 2003 server (64 bit).   We have 32 GB of physical RAM.   In SSMS here are the current settings:  (These were the default values.)  

Use AWE to allocate memory = NOT CHECKED
Minimum Server Memory = 0
Maximum Server Memory = 2147483647

When I look at the taskmgr in Windows, it consistently shows sqlservr.exe taking almost all 32 GB of memory (even when CPU is low and there's nothing really being done in SQL).    Is this normal?   Input would be appreciated.   Thanks!
Question by:colorbok
    LVL 9

    Expert Comment

    There were several reasons for this and to be checked. Check your memory options and System log file for more info.
    LVL 14

    Accepted Solution


    I got the below options from a blog:

    If 64 Bit and enterprise make sure you lock pages in memory.

    How to: Enable the Lock Pages in Memory Option (Windows)
    Updated: 14 April 2006
    The Windows policy Lock Pages in Memory option is disabled by default. This privilege must be enabled to configure Address Windowing Extensions (AWE). This policy determines which accounts can use a process to keep data in physical memory, preventing the system from paging the data to virtual memory on disk. On 32-bit operating systems, setting this privilege when not using AWE can significantly impair system performance. Although not required, we recommend locking pages in memory when using 64-bit operating systems.
    Use the Windows Group Policy tool (gpedit.msc) to enable this policy for the account used by SQL Server 2005 Database Engine. You must be a system administrator to change this policy.
    For a table that lists the maximum server memory values, see Memory Architecture.
    To enable the lock pages in memory option
    1. On the Start menu, click Run. In the Open box, type gpedit.msc.
    The Group Policy dialog box opens.
    2. On the Group Policy console, expand Computer Configuration, and then expand Windows Settings.
    3. Expand Security Settings, and then expand Local Policies.
    4. Select the User Rights Assignment folder.
    The policies will be displayed in the details pane.
    5. In the pane, double-click Lock pages in memory.
    6. In the Local Security Policy Setting dialog box, click Add.
    7. In the Select Users or Groups dialog box, add an account with privileges to run sqlservr.exe.

    Make sure you set MIN memory i got mine set to 8196 and make sure the MAX Memory is set too...(i have 64 gig ram so put in 51260 for 51 GIG).

    For more info:


    Author Closing Comment

    Thank you.

    Featured Post

    What Should I Do With This Threat Intelligence?

    Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

    Join & Write a Comment

    If you having speed problem in loading SQL Server Management Studio, try to uncheck these options in your internet browser (IE -> Internet Options / Advanced / Security):    . Check for publisher's certificate revocation    . Check for server ce…
    So every once in a while at work I am asked to export data from one table and insert it into another on a different server.  I hate doing this.  There's so many different tables and data types.  Some column data needs quoted and some doesn't.  What …
    This video discusses moving either the default database or any database to a new volume.
    Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    15 Experts available now in Live!

    Get 1:1 Help Now