Datasource TestDB1 could not be found.

Posted on 2011-04-26
Last Modified: 2012-05-11
I've got another website that when you go to it will throw an error and say:

Datasource TestDB1 could not be found.

But if you refresh it, it will load correctly.


Datasource TestDB1 could not be found. The specific sequence of files included or processed is: /var/www/vhosts/, line: 1


"Error","jrpp-54897","04/25/11","17:26:22",,"Datasource TestDB1 could not be found. The specific sequence of files included or processed is: /var/www/vhosts/, line: 1 "
      coldfusion.tagext.sql.QueryTag$DataSourceException: Datasource TestDB1 could not be found.
       at coldfusion.tagext.sql.QueryTag.doStartTag(
      at cfindex2ecfm928221571.runPage(/var/www/vhosts/
      at coldfusion.runtime.CfJspPage.invoke(
      at coldfusion.tagext.lang.IncludeTag.doStartTag(
       at coldfusion.filter.CfincludeFilter.invoke(
       at coldfusion.filter.ApplicationFilter.invoke(
       at coldfusion.filter.RequestMonitorFilter.invoke(
       at coldfusion.filter.MonitoringFilter.invoke(
       at coldfusion.filter.PathFilter.invoke(
       at coldfusion.filter.ExceptionFilter.invoke(
       at coldfusion.filter.ClientScopePersistenceFilter.invoke(
       at coldfusion.filter.BrowserFilter.invoke(
       at coldfusion.filter.NoCacheFilter.invoke(
       at coldfusion.filter.GlobalsFilter.invoke(
       at coldfusion.filter.DatasourceFilter.invoke(
       at coldfusion.CfmServlet.service(
       at coldfusion.bootstrap.BootstrapServlet.service(
       at jrun.servlet.FilterChain.doFilter(
       at coldfusion.monitor.event.MonitoringServletFilter.doFilter(
       at coldfusion.bootstrap.BootstrapFilter.doFilter(
       at jrun.servlet.FilterChain.doFilter(
       at jrun.servlet.FilterChain.service(
       at jrun.servlet.ServletInvoker.invoke(
       at jrun.servlet.JRunInvokerChain.invokeNext(
       at jrun.servlet.JRunRequestDispatcher.invoke(
       at jrun.servlet.ServletEngineService.dispatch(
       at jrun.servlet.jrpp.JRunProxyService.invokeRunnable(
       at jrunx.scheduler.ThreadPool$DownstreamMetrics.invokeRunnable(
       at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(
       at jrunx.scheduler.ThreadPool$UpstreamMetrics.invokeRunnable(
       Caused by: com.mysql.jdbc.CommunicationsException: Communications link failure due to underlying exception:
Question by:binarybilly
    LVL 51

    Expert Comment

    Caused by: com.mysql.jdbc.CommunicationsException: Communications link failure due to underlying exception:

    .... But if you refresh it, it will load correctly.

    It's entirely possible this is a slightly different manifestation of the same problem as in your other thread.  What's the rest of the error beyond that line?

    Author Comment

    37       STACKTRACE:
    39       at com.mysql.jdbc.MysqlIO.readFully(
    40       at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    42       at com.mysql.jdbc.MysqlIO.sendCommand(
    43       at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    44       at com.mysql.jdbc.Connection.execSQL(
    45       at com.mysql.jdbc.Connection.setCatalog(
    46       at coldfusion.server.j2ee.sql.JRunConnection.setCatalog(
    47       at coldfusion.server.j2ee.sql.JRunConnectionHandle.setCatalog(
    48       at coldfusion.tagext.sql.QueryTag.doStartTag(
    49       at cfindex2ecfm928221571.runPage(/var/www/vhosts/
    50       at coldfusion.runtime.CfJspPage.invoke(
    51       at coldfusion.tagext.lang.IncludeTag.doStartTag(
    52       at coldfusion.filter.CfincludeFilter.invoke(
    53       at coldfusion.filter.ApplicationFilter.invoke(
    54       at coldfusion.filter.RequestMonitorFilter.invoke(
    55       at coldfusion.filter.MonitoringFilter.invoke(
    56       at coldfusion.filter.PathFilter.invoke(
    57       at coldfusion.filter.ExceptionFilter.invoke(
    58       at coldfusion.filter.ClientScopePersistenceFilter.invoke(
    59       at coldfusion.filter.BrowserFilter.invoke(
    60       at coldfusion.filter.NoCacheFilter.invoke(
    61       at coldfusion.filter.GlobalsFilter.invoke(
    62       at coldfusion.filter.DatasourceFilter.invoke(
    63       at coldfusion.CfmServlet.service(
    64       at coldfusion.bootstrap.BootstrapServlet.service(
    65       at jrun.servlet.FilterChain.doFilter(
    66       at coldfusion.monitor.event.MonitoringServletFilter.doFilter(
    67       at coldfusion.bootstrap.BootstrapFilter.doFilter(
    68       at jrun.servlet.FilterChain.doFilter(
    69       at jrun.servlet.FilterChain.service(
    70       at jrun.servlet.ServletInvoker.invoke(
    71       at jrun.servlet.JRunInvokerChain.invokeNext(
    72       at jrun.servlet.JRunRequestDispatcher.invoke(
    73       at jrun.servlet.ServletEngineService.dispatch(
    74       at jrun.servlet.jrpp.JRunProxyService.invokeRunnable(
    75       at jrunx.scheduler.ThreadPool$DownstreamMetrics.invokeRunnable(
    76       at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(
    77       at jrunx.scheduler.ThreadPool$UpstreamMetrics.invokeRunnable(
    78       at
    79       ** END NESTED EXCEPTION **
    LVL 51

    Expert Comment

    Yeah, I think it's the same driver issue.  This person reported that adding the same validation query (ie "SELECT 1") solved the EOF error for them

    Author Comment

    I will give it a shot.
    LVL 51

    Accepted Solution

    Ok. While I've seen 2 or 3 error messages related to this mysql driver issue,  the one thing they tend to have in common is the sporadic nature of the problem. ie "If you refresh, the problem goes away."  That's what makes me suspect it's the same underlying driver problem.
    LVL 15

    Expert Comment

    if you are on shared host ask your provider to update the driver, it will resolve th issue as agx has rightly said

    Author Closing Comment

    select 1 seemed to be the fix again. I'm going to apply this to all my datasources. Thanks agx!
    LVL 51

    Expert Comment

    Yeah, if they're all mySQL dsn's .. probably a good idea  :) AFAIK it's only an issue w/the MySQL drivers. Cheers


    Featured Post

    What Should I Do With This Threat Intelligence?

    Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

    Join & Write a Comment

    Suggested Solutions

    This article  is about submitting  form through  ColdFusion.Ajax.submitForm to the action page and send a response back in JSON format which later can be decoded using ColdFusion.JSON.decode. By this way you can avoid the usual page refresh for subm…
    PROBLEM: How to add your own buttons to the bottom toolbar with paging info ( result count ). While creating a cfgrid, I ran into an issue where I wanted to embed my own custom buttons where the default ones ( insert / delete / etc… ) are for aes…
    Hi everyone! This is Experts Exchange customer support.  This quick video will show you how to change your primary email address.  If you have any questions, then please Write a Comment below!
    Here's a very brief overview of the methods PRTG Network Monitor ( offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

    734 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    18 Experts available now in Live!

    Get 1:1 Help Now