WebDAV Authentication Issues

When accessing a folder via WebDAV on a SharePoint site behind Threat Management Gateway the end user will occasionally prompted for windows credentials.  The site being accessed uses forms based authentication using persistent cookies while the connection TMG utilizes for SharePoint is NTLM. Under normal working conditions the user is not prompted for any credentials when using WebDAV after first logging in.

The issue can be temporarily resolved by restarting the windows service called 'Web Client' but eventually the problem will come back.  We've been able to recreate the issue by accessing a resource we don't have permission to read. Any following navigation requests will prompt the user for credentials.

The clients accessing the web folder are running Windows 7.  The TMG server is running Windows Server 2008 R2 with SP 1.  The SharePoint site is running Windows server 2003 and MOSS, though the issue still exists on our SharePoint 2010 Enterprise box that is running Windows 2008 R2 with SP1.
schal1rAsked:
Who is Participating?
 
Keith AlabasterEnterprise ArchitectCommented:
There is a significant update to TMG 2010 SP1 http://www.microsoft.com/downloads/en/details.aspx?FamilyID=695d0709-0d8b-45ee-afdb-727c4428ca4d
There are also 3 rollups to this also.
0
 
Keith AlabasterEnterprise ArchitectCommented:
and the FTMG - running SP1 with updates and rollups applied?
0
 
schal1rAuthor Commented:
The FTMG has SP1 installed both on the windows side and the TMG side.  I don't believe there are any rollups applied.  
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
schal1rAuthor Commented:
I'll be requesting these updates get installed on our test server tomorrow and see if the issue remains.  
0
 
lzldmbCommented:
It appears that this issue is resolved in Update 1 to Threat Management Gateway 2010 SP1. We have it installed in our testing environment and we have not seen any issues so far.
0
 
schal1rAuthor Commented:
As it were, the Update for TMG had been applied to our test enviroment but never moved up to our production.  It does infact seem that the update resolves our WebDAV issue.
0
 
Keith AlabasterEnterprise ArchitectCommented:
Excellent, good news.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.