Joomla 1.5 Web Install Database Configuration hangs

Posted on 2011-04-26
Last Modified: 2012-05-11
Here is my issue
Installed WAMP on 2003 Server
Going to use for intranet CMS
Decided to go with Joomla 1.5
Am using port 81 do differentiate from internet site on IIS on same box

When I enter information on step 4 Database Configuration the page just spins and times out blank

 Screen Shot of page before hitting next
Not a total novice but I wear a lot of hats

Thanks ahead of time.
Question by:fpstech
    LVL 7

    Accepted Solution

    Guessing you have 2 SQL databases listening on the same port.  One for IIS and another for WAMP.  You could test this by shutting down your IIS server and see if you still time out.  You will have to change the SQL port from 1433 in the WAMP configurations.  Or configure WAMP to use your existing database.

    Author Comment

    Hey Bill,

    Thanks for the quick response...I am going to be honest I don't really know how I got this to work but here are the processes.

    Verified that there was just one database check
    Had MySql in the past and used it in conjunction with ColdFusion but had deleted old install of MySql
    Tried to connect with ColdFusion to new MySql database
    Had to download and install mysql-connector-odbc driver
    Tried to connect with IP without port 81 spit out error concerning an old host name I used in the past
    Opened host file and found old mappings that needed to be deleted
    Tried to connect with IP no go
    Mapped to localhost
    Tried with localhost

    I can't say I am 100% comfortable with the result so will keep this open until Joomla is up and running if thats ok

    Any input as to how or why this happened would be greatly appreciated
    LVL 1

    Assisted Solution

    MySQL from WAMP runs on port 3306 and you do not specify the port in the connector.  It also is setup in WAMP by default to only allow connections from "localhost", so using the IP will not work either.  

    Do you get a running status for MySQL from WAMP?  Just concerned that an old install might be running causing your problems.  

    When you try with localhost, what is the error you get?  Can't connect, not authorized, etc.

    If you go to Windows Services, do you see a MySQL running?  If so, stop it, and then restart all WAMP Services and try again.

    Author Closing Comment

    Thanks guys, the bit about the IP is helpful and I now have it running, it was the way my host file was set up pointing local host to the IP.

    Once I changed that everything went pretty smooth so I am diving in to Joomla thanks again guys

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Looking for New Ways to Advertise?

    Engage with tech pros in our community with native advertising, as a Vendor Expert, and more.

    What you will need: Any version of Photoshop or similar product (examples in Photoshop) Internet Access FTP Access to your joomla install or ability to upload images within joomla administrator backend Create Image: Lets start off with cre…
    It is possible to boost certain documents at query time in Solr. Query time boosting can be a powerful resource for finding the most relevant and "best" content. Of course the more information you index, the more fields you will be able to use for y…
    The purpose of this video is to demonstrate how to set up the WordPress backend so that each page automatically generates a Mailchimp signup form in the sidebar. This will be demonstrated using a Windows 8 PC. Tools Used are Photoshop, Awesome…
    how to add IIS SMTP to handle application/Scanner relays into office 365.

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    21 Experts available now in Live!

    Get 1:1 Help Now