[Last Call] Learn how to a build a cloud-first strategyRegister Now


How do I hide the Content Editor Web Part in SharePoint 2010

Posted on 2011-04-26
Medium Priority
Last Modified: 2012-05-11
I have added a cewp to my sharepoint 2010 page. I want to hide the webpart. When I click Edit the WebPart and expand the Layout section, the Hidden checkbox is grayed out. Is there something I am missing? Thanks in advance.
Question by:scurry888
  • 5
  • 3
LVL 38

Assisted Solution

by:Justin Smith
Justin Smith earned 1000 total points
ID: 35471338
Can you hit the drop down arrow in the top right corner, and hit "close"?

Author Comment

ID: 35475108
When I click the arrow in the top right corner of the CEWP the options I have are: Minimize, Edit Web Part and Export. I clicked on Edit Web Part and expanded the Advanced section this is what i have.

 CEWP advanced section
LVL 38

Expert Comment

by:Justin Smith
ID: 35482788
You need to select "Edit Page" in the ribbon before the Close option will show up
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.


Author Comment

ID: 35483396
I selected 'Edit Page' in the ribbon and then clicked on the dropdown arrow in the CEWP. The options that I have now are :  cewp menu
Next I selected 'Edit Web Part' the options under the Layout and Advanced sections are stilled grayed out. I am not able to make any changes to them.
  cewp properties
Is there a setting I have missed in Central Administration to allow these changes?
LVL 38

Expert Comment

by:Justin Smith
ID: 35483410
No.  Explain to me why you can't just delete or minimize it?

Author Comment

ID: 35484442
In SP2007 I used the CEWP to modify the page by adding code (CSS or javasript) to the CEWP. I would then just hide it. If I minimize the CEWP the user can just restore it. If I delete it then I am not able to modify the page.

Accepted Solution

scurry888 earned 0 total points
ID: 35486414
This is what I found.I was not able to hide the CEWP on publishing pages. if I created a webpart
page and added the CEWP I was able to hide it without any problems. The workaround that I found
was to add this querystring to my URL '?ToolPaneView=2'.


This opens an Add Web Parts dialog and allows me to add the CEWP at the bottom of the page. I am
now able to hide the web part without any problems.

Author Closing Comment

ID: 35687819
Appending the query string to the end of the URL allowed me to add the CEWP to my page and hide it .

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SharePoint Designer 2010 has tools and commands to do everything that can be done with web parts in the browser, and then some – except uploading a web part straight into a page that is edited in SPD. So, can it be done? Scenario For a recent pr…
The vision: A MegaMenu for a SharePoint portal home page The mission: Make it easy to maintain. Allow rich content and sub headers as well as standard links. Factor in frequent changes without involving developers or a lengthy Dev/Test/Prod rel…
This video shows how to quickly and easily deploy an email signature for all users in Office 365 and prevent it from being added to replies and forwards. (the resulting signature is applied on the server level in Exchange Online) The email signat…
Loops Section Overview
Suggested Courses
Course of the Month17 days, 17 hours left to enroll

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question