Dell Dimension 2400 Samsung SW-252S CD Rom not recognized

Posted on 2011-04-26
Last Modified: 2012-06-21
This should be fairly easy to solve.  I tried everything I can think of and still no go.'

Dell Dimension 2400 Desktop computer running Windows XP Pro.

The computer does not display the CD Rom drive in My Computer.  I cannot access the drive at all.  I tried downloading a firmware upgrade for the drive but it failed because the computer cannot see the drive.  

In control panel it does recognize the drive but there is the yellow exclamation point next to it.  
I figured I could update the drive from device manager but I cannot seem to find the driver in .inf format to update it. I tried Dell's website and all they have is the Firmware update and no driver.  

I tried uninstalling the driver and rolling back the driver both with no luck.

Any suggestions?   Device Manager
Question by:Mr_JS
    LVL 6

    Accepted Solution

    LVL 6

    Expert Comment

    by:Kris Montgomery
    Found this on another website:

    Good luck.
    LVL 87

    Expert Comment

    There wouldn't be a CD Rom driver, you'd rather need the Controller interface driver which is usually part of the chipset drivers. Most of the times those general IDE drivers are already included in the OS, so that also reduces the need for extra drivers.

    First of all try booting a bootable CD, because if that doesn't work the drive is bad and needs to be replaced. If you can boot from the CD uninstall any packet writing tools like InCD (part of Nero), or DirectCD (part of Roxio). Reboot, then remove the upper and lower filters (follow the instructions in the Link), then reboot again and check if it now works.
    LVL 6

    Expert Comment

    If this CD unit has jumpers, put it as a master if only one on the IDE cable.  If sharing the cable with a hard drive, make the hard drive jumper as master and the CD jumper as secondary.
    If this doesn't work then the CD unit is toast.

    Author Comment

    Thanks @muganthony.  It must have been some old registry entries.  Dougknox utilities fixed this problem right up.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Highfive + Dolby Voice = No More Audio Complaints!

    Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

    This is about my first experience with programming Arduino.
    What do we know about Legacy Video Conferencing? - Full IT support needed! - Complicated systems at outrageous prices! - Intense training required! Highfive believes we need to embrace a new alternative.
    The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
    The viewer will learn how to back up in Windows 7 with native tools. This should be the first step. Third party tools should also be used. Access the Backup and Restore options: Click on the windows 7 start ball in the lower left corner of the scree…

    760 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    7 Experts available now in Live!

    Get 1:1 Help Now