Access2010 Report Wizard Date Grouping


.mdb file on NAS.  Access 2000/2010 mixed multiuser
The best i can tell, VBA format (date) procedure is not working.  To keep things simple, i run the query or report wizard and group/summarize on a date field.
If i start a new table with dates, it works.  On my existing tables (which are commonly filled with the now() function), it doesn't.
Errors: "...table is in exclusive mode..."  and " ..invalid procedure call.."
boardtesterAsked:
Who is Participating?
 
boardtesterConnect With a Mentor Author Commented:
Understood.  I was hoping that the "...table is in exclusive mode..."  and " ..invalid procedure call.." was a signature that someone would recognize.

By procedure I mean that the wizard uses the Format function and then it gives different error messages than when the query is run alone.

The query alone started giving "reserved error -1524", which led me to check for data corruption.  Found the bad records, deleted, all is well.  Thanks.

Chris
0
 
Jeffrey CoachmanMIS LiasonCommented:
There are a lot of mysteries here...:

1. <VBA format (date) procedure>
What "(date) procedure" are you referring to?
In Access there is a Date *Function*...: Date()
...Is this what you mean?
Are you saying that if to do this: =Date()
...nothing happens?

2. <VBA format (date) procedure is not working>
Can you clearly define what you mean by "Not Working" please?

3. Please remember that the NOW() function includes a Time component, ...this may be a factor in your mysterious "Not working" issue.

4. <i run the query or report wizard and group/summarize on a date field.>
Can I ask what you are summarizing, and on what field?

As you can see, it would probably be best if you posted a sample of this DB.
Sample database notes:
1. Back up your database(s).
2. Combine the front and back ends into one database file.
3. Remove any startup options, unless they are relevant to the issue.
4. Remove any records unless they are relevant to the issue.
5. Delete any objects that do not relate directly to the issue.
6. Remove any references to any "linked" files (files outside of the database, Images, OLE Files, ...etc)
7. Remove any references to any third party Active-x Controls (unless they are relevant to the issue)
8. Remove, obfuscate, encrypt, or otherwise disguise, any sensitive data.
9. Compile the code. (From the database window, click: Debug-->Compile)
10. Run the compact/Repair utility.
11. Remove any Passwords and/or security.
12. Post explicit steps to replicate the issue.
13. Test the database before posting.

In other words, ...post a database that we can easily open and immediately see the issue, and if applicable, also include a Graphical representation of the Exact results you are expecting.

JeffCoachman



0
 
Jeffrey CoachmanMIS LiasonCommented:
ok
0
 
boardtesterAuthor Commented:
poorly asked question becasue i underestimated the rarity of the problem
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.