Have to keep rebooting server

An office environment, two desktops running Win Xp pro.   Server running Windows 7.   Quickbooks on Win 7.  Both desktops access quickbooks off server one at a tiime.   Lately, the server needs to be rebooted each morning for the two workstations to get access to quickbooks.  Any ideas why?    They are also accessing internet through DSL.
syssolutAsked:
Who is Participating?
 
jon1966Connect With a Mentor Commented:
Can you ping the Win7 workstation in the morning?  I suspect the Win7 workstation is going into sleep mode and the NIC is being turned off.


J
0
 
PlantwizCommented:
For starters, Windows 7 isn't a true 'server'.  Server software is something like Windows 2000, 2003, 2003 R2, 2008 or 2008 R2.

So, are you running a peer-to-peer network with a file server?  Or how are you setup?

Also, is your Quickbooks licensed for 3 users?
0
 
syssolutAuthor Commented:
I believe the Quickbooks is for 3 people since they have been using it for the past 2 years.   I understand Win 7 isn't true server software, but before this "server" they had been using Win 2000 as a server software and it worked for them.   This server has been this way for at least 1 year and it has worked fine up until recently.   If the NIC card is going to sleep, how can I change this?
0
Managing Security & Risk at the Speed of Business

Gartner Research VP, Neil McDonald & AlgoSec CTO, Prof. Avishai Wool, discuss the business-driven approach to automated security policy management, its benefits and how to align security policy management with business processes to address today's security challenges.

 
jon1966Commented:
I would see if the server can be pinged, before attempting the reboot.
0
 
PlantwizConnect With a Mentor Commented:
Windows 7 does default to having the nic sleep

See here where it is controlled:
http://www.addictivetips.com/windows-tips/stop-network-adapter-from-getting-disabled-in-windows-7/

Good on the an licensing!  I have seen issues when too few licensing were attempting to access the app from another location.  3 license packs are very common so this is not likely the problem for you.



But the sleeping nic could be.
Did your problem begin when you started using windows 7?
0
 
PlantwizCommented:
Nic adapter found in device manager | properties | Power management tab

Uncheck the box "allow computer to turn off..."


(I have a limited viewing screen but the link should have the graphics I cannot send from this device)
0
 
syssolutAuthor Commented:
No, when server setup  almost a year ago until abbout 2 weeks ago, they have had this issue.
0
 
jon1966Commented:
syssolut - your description of the problem is vague and could be application or network related as no error messages have been provided.  The ping test would possibly rule out network issues, while on the application side the QB"s licensing service might be hung.  Understood that it started 2 weeks ago, but troubleshooting both network and application are required.
0
 
PlantwizCommented:
Please check the nic in device manager.

Also check event logs for any reported errors.

If the problem is new, what has recently changed?  Have you run any updates recently?  There may have been an update that caused some settings to change.

0
 
syssolutAuthor Commented:
From what I have been told now, it is once in a while in the morning that the server needs to be restarted.   The server and computers stay on all night.
0
 
PlantwizCommented:
Windows Desktop software by it's nature seems to need to be rebooted 'once in a while'.  Even Windows 7, though this is the best desktop software from MS I've used to date (and I was very happy with XP).

Are your users logging out of all the applications at the end of the day?  Or are they leaving apps open?

Did you check that NIC power as described above?  
How about error logs?

If there is nothing in the error logs, then please have your users start recording circumstances aroudn when they find they need to reboot.
0
 
syssolutAuthor Commented:
I switched off let the computer shut this item down to save power.  So far it is working.   Thanks
0
 
PlantwizCommented:
Thank you for the update!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.