• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1068
  • Last Modified:

Remote Desktop Gateway - getting internal server hostname & certificate

I have imported and set 3rd party issued certificate for Remote Web Access using SBS wizard. Web services (OWA, RWA, etc.) work fine.

However when I want to connect remotely, through internet,  using Remote Desktop Client I am offered self-issued certificated for internal domain name "sernamename.domain.local".

I have installed "Remote Desktop Gateway manager" but I have found somewhere that it should not be used for setting certificate in SBS 2011...

Thank you for help
RDC-notification.jpg
0
AndyBross
Asked:
AndyBross
  • 4
  • 3
  • 2
  • +1
1 Solution
 
Shreedhar EtteCommented:
Have you imported the 3rd party certificate at Remote Desktop Gateway. Cross verfiy by refer the below article:
http://technet.microsoft.com/en-us/library/cc753931.aspx
0
 
AndyBrossAuthor Commented:
Hello

as it is written in the following link : " The RD Gateway is properly configured for use with the Remote Web Access site by Small Business Server setup."
http://support.microsoft.com/kb/2472211

so I am not sure if I should use RD Gataway Manager to configure certificate ...?

may be this could help me  ?
http://technet.microsoft.com/en-us/library/gg697165.aspx
0
 
Shreedhar EtteCommented:
Have you checked Remote Desktop Gateway settings for the certificate configured. Does it is same as 3rd party certificate?

No Need to Repair.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Connecting to desktops within an SBS 2008 network is generally done through RWW.

You will not get that error message if you connect via RWW.

However, if you want to connect directly via RDP, then you will get that message... of course, you can just click the box on the bottom to not show it to you again when connecting from the same computer.  

Since RDP to your server is for administrative purposes only, this generally isn't an issue as regular users won't encounter this error.

I do not suggest configuring the RDP gateway on an SBS Network as it is really unnecessary and just one more thing you would need to manage.

Why aren't you using RWW?

Jeff
TechSoEasy
0
 
AndyBrossAuthor Commented:

Jeff, thank you.

RWW, now called RWA I dont like because its start is bit slowly ..

I have just found out that even when I use RWA I  first get public certificate (proper one) followed by internal , please see attachements.

I am surprise that MS say that it  " may not " !! be working in case of setting certificate for RD Gateway. Is there any added value connecting to computers through RWA ? I see one .. list of all domain computers. I think it could be quite handy use RDG..
rwa-s1.jpg
rwa-s2.jpg
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
So I'm wondering if you've made sure that your SBS trusts the intermediary certificate?

Please be sure to review all of the things on this blog post, especially the stuff at the bottom:
http://blogs.technet.com/b/sbs/archive/2011/03/10/introduction-to-sbs-2011-remote-web-access-rwa.aspx

Jeff
TechSoEasy
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
Y'know... you can also import the SSL cert right to the RD Gateway manager.  Follow the steps here to get access:
http://support.microsoft.com/kb/2472211

Jeff
TechSoEasy
0
 
Shreedhar EtteCommented:
Any progress on this?
0
 
a1computer1Commented:
i also have same problem and i imported directly into remote desktop gateway after initializing it.
Bye the way i can not ok internally to http://mail.affordputerservices.com
redirected to https://mail.affordputerservices.com/remote

log into RWA
select connect to computer
select server
get public mail.affordputerservices.com go daddy cert
get windows log in sceurity screen insert name and pass and be into server with no errors

externally error happens after presented wtih security screen which says it is logging me into remote destop gatewway then self issed cert appears with .local
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now