Exchange 2010 certification issue

Hi,

I just purchased UC certificate from Globalsign. ICBExc2010GS is new certificate and I have tryed to assign services but it asked me if I wanna overwrite existing certificate and I said No! At the moment internally Globalsign certificate is active and working fine but externally still old certificate working. I just wanna take the steps carefully, so could you guide me with safe way please?


 certificate
LVL 8
teomcamAsked:
Who is Participating?
 
Shreedhar EtteCommented:
Do not create the Rule...Modify the OWA-Exchange 2010 rule and at Select Certificate options..Select the Certificate which you just now added.

0
 
Shreedhar EtteCommented:
At the over writre promot you should have said Yes.
0
 
teomcamAuthor Commented:
Should I try assign again or its too late? Could you give more details please?
0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
Shreedhar EtteCommented:
try assign again.
0
 
teomcamAuthor Commented:
I just tryed and assigned and overwritted but externally still old one appearing.
0
 
Shreedhar EtteCommented:
- Open Internet Information Services (IIS) Manager.

- Select the Default Web Site > Click Bindings > Select the port 443> View Certificate> it has to be ICBExc2010GS.

- If not select the ICBExc2010GS > Click Ok.

- Restart the IIS Admin Service.

Does you have ISA?
0
 
teomcamAuthor Commented:
Hi,
I tryed and restarted IIS Admin service but still same. Yes, I have TMG2010 (ISA).
0
 
Shreedhar EtteCommented:
You need to install the certificate on TMG2010 on the OWA rule.
0
 
teomcamAuthor Commented:
Hi shreedhar,
I just imported the same new certificate of exchnage 2010 to the TMG2010's Computer/Personal certificates. As you can see below there is an existing OWA rule called OWA-Exchange 2010. According to that should I still create another OWA rule?

 tmg2010
0
 
teomcamAuthor Commented:
Well that intersting why Globalsign certificate is not valid?

 weblistener
0
 
Shreedhar EtteCommented:
Have you also installed the Intermidiate certificate in the TMG 2010?
0
 
teomcamAuthor Commented:
I have purchased OV certificate and they sent me 2 certificates. Intermediaet also not valid. When I make request I did not include TMG's name or IP. Would it be the problem?


One of them says: MUST BE INSTALLED ON YOUR WEB SERVER:
Your SSL Certificate (Formatted for the majority of web server
software including IIS and Apache based servers):

Other one says:

MUST BE INSTALLED ON YOUR WEB SERVER:
OrganizationSSL Intermediate Certificate (SGC version):

 intermediate
0
 
Shreedhar EtteCommented:
Refer this article to install the certificates on TMG 2010:
http://www.globalsign.com/support/intermediate/organizationssl_intermediate_exchange.php
0
 
teomcamAuthor Commented:
Hi again,
I found the problem. After assig the new certificate we had to export private key and import to TMG2010. After that certificate became to valid and now new certification published succesfully. Thanks very much for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.