System restore problem with Windows Vista

Posted on 2011-04-27
Last Modified: 2012-05-11
I have a Windows Vista laptop that won't start up.  Whenever this happens, and I run the start repair, I've never had the fortune to have startup repair work.  I've also never had System Restore work in these circumstances - ever.  It always says that there are no restore points.

Is there a method by which I can plug the drive into a USB adapter on another PC, and manually copy the files from a repair folder in windows, or whatever.  I'd rather avoid factory reinstall if I can.
Question by:DaveWWW
    LVL 40

    Accepted Solution

    The answer is NO. You cannot fix the computer by just copying the files. Try the following instead.

    "Cannot boot" up can mean many problems. The HDD may fail and will fail soon or the boot record is damaged or the boot sector is over-written by rootkit virus.

    What is your symptom? Just a command cursor or a black screen with white mouse pointer or something else? Any warming message?

    1. Start the computer with Vista Setup DVD or System Recovery Disc

    2. Goto Command Prompt in Vista Recovery Environment

    Note: A tutorial of Using Command Prompt in Vista Windows Recovery is in the URL below.


    3. Run the command below.

        chkdsk /r

    4. Restart computer and if still cannot boot into Windows, you need to run the following command in command prompt of vista recovery console.

       Bootrec /FixMbr

       Bootrec /FixBoot

    Author Comment

    That didn't work, sorry to say.  I get BAD_POOL_HEADER with an error of 0x00000019.

    The one strange thing is that when I run CHKDSK I get all kinds of Index entries deleted from recognizable files (seemingly from the Windows folder among others), and when CHKDSK finishes it says it has made changes to the file system.  Yet when I re-run CHKDSK it finds exactly the same problem and fixes it all again.  Nothing stays fixed.  I've never seen this happen before.  

    The startup diagnostic shows no disk problems at all, and when I put this drive into another USB adapter for a look, all seems fine.
    LVL 40

    Expert Comment

    by:Jackie Man
    "....and when I put this drive into another USB adapter for a look, all seems fine." <- try to run a chkdsk / r for the drive when you attached it via another USB adapter.

    Besides, have you run MemTest86 to test the installed memory module?
    LVL 4

    Expert Comment


    This MSDN article suggests that you should have a parameter - they have list of what the parameter codes mean. At the end of the article there is a suggestion to use the driver verifier, but I think you can only use this within Windows. The driver verifier link below provides a lot more information.

    It sounds like you may have a bad  or corrupt driver. Have you tried to use the "Last Known Good Configuration" option from the Windows Startup Options (hitting F8 slightly before the Windows Loading Screen)?

    Author Closing Comment

    That's what I needed to know!  Thanks.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Do You Know the 4 Main Threat Actor Types?

    Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

    Suggested Solutions

    Title # Comments Views Activity
    Free tools for PC repair 23 581
    malware removal 5 644
    How to repair Vista SP2 Installations? 6 486
    IE Add-ons Remove 11 114
    Hi All Just a quick one for everybody. I was recently looking into setting the default User Account Picture for all my vista clients within the network but on closer inspection the group policy setting only allows you to set the default pictur…
    So who is this article for? If you are like most of the computer users out there, you probably only realize the meaning of 'System maintenance' after something goes wrong. This article is for you if you care about keeping your system working opti…
    The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
    Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    22 Experts available now in Live!

    Get 1:1 Help Now