[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2701
  • Last Modified:

VirtualBox and keyboard-problem

Hi,
I have a PC with:

OS: Fedora 14.
VirtualBox
Wine
TeamViewer

When I start a VM in VirtualBox through TeamViewer I cannot click any other letters then A-Z. !"#/()=)=^*_:; and such are disabled.
0
hke72
Asked:
hke72
  • 8
  • 6
1 Solution
 
schwabdaleCommented:
Have you tried a different Distro? May Ubuntu?
Do you have a "High tech" keyboard?
0
 
schwabdaleCommented:
Also, have you install Guest Additions?
0
 
schwabdaleCommented:
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
hke72Author Commented:
Hi,
I installed scim-bridge-qt NOT scim-bridge-client-qt because I did not find it. But it did not help. But the name sugests some brige between host and guest. Host is Fedora 14 and guest is Win 2008 R2.

??
0
 
schwabdaleCommented:
Did you install Guest additions?
Also, is this a USB Keyboard?
0
 
schwabdaleCommented:
If you go into settings in Virtualbox...you should see a usb area. Do you have the box checked for "2.0"?
Also, I'm not familiar with Fedora. But, in Ubuntu you can add your user account the the VBoxusers group.
It could be a Permissions/USB issue. You could try to run your Virtual Machine as Administrator.
0
 
hke72Author Commented:
Hi,
USB was not OK, but fixing it did not help.

- I have installed Guest Addition
- My problem only happens if I start the VM through TeamViewer! When on site there is no problem. So USB keyboard should not be an issue!?
- I have checked 2.0 in the USB-area (and it was unchecked!)
- I added the user to the group vboxusers using GUI "User Manager"
- I still wonder about the scim-bridge-client-qt and scim-bridge-qt and if I need to do some configuring here.
0
 
schwabdaleCommented:

Maybe you need to install scim-bridge-client-qt
To be honest, I don't know much about this. But, I would think if you could find it and install it, maybe that will work.

Also, I noticed in virtualbox...sometimes if you "minimize/maximize" the VM, or "exit/re-enter" full screen mode, it fixes little bugs.
0
 
hke72Author Commented:
Arghh...

I did a full change of OS to Ubuntu 11.04. Installed VirtualBox and Teamviewer and connected to the same guest. Exactly the same problem.

I installed "scim-bridge-client-qt" and disabled "Automatic discover" keyboard in settings of VirtualBox.

Could it have something to do with me using a Norwegian keyboard? I set everything to use Norwegian keyboard.

Are there config-files for TeamViewer? And where would I find them?
0
 
schwabdaleCommented:
Do you have another keyboard to try?
0
 
hke72Author Commented:
Well, I have tried to switch my physical keyboard at the remote site. It was also Norwegian, but since the keys do not show any registration at all...
0
 
schwabdaleCommented:
I would suggest trying a different remote control site such as Logmein, or showmypc.com. From my understanding, Virtualbox has
some bugs..this could be one of them.
0
 
hke72Author Commented:
I tried installing Ubuntu, Teamviewer and got the same result. After that I gave up.

Thank you for trying!
0
 
hke72Author Commented:
Never solved!
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 8
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now