Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 805
  • Last Modified:

Modify Calendar width in drupal 6

Hi All,
I created a calendar for my drupal 6 website and it is spiling over the site content. The screenshot is attached. I think this can be fixed with CSS, but don't know exactly where to modify it.  I have been trying some stuff but nothing is changing. Can someone help fix it please?? The file The file
0
ritelo
Asked:
ritelo
  • 9
  • 8
1 Solution
 
jonahzonaCommented:
Is a link possible? Or maybe the code from the parsec HTML page?
0
 
riteloAuthor Commented:
Here you go... code.txt
0
 
riteloAuthor Commented:
But I think that it should be done in the Calendar module... I might be wrong...
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
jonahzonaCommented:
i would try adjusting the table.full selector.

Maybe first try something like:

table.full {
  width: 500px !important;
}

Open in new window


If this doesn't work, maybe you could post your css too so I could give it a once over.
0
 
riteloAuthor Commented:
Here is the CSS. The above solution doesn't seem to work. calendar.css
0
 
jonahzonaCommented:
If there is anyway to view this live, it would make this a lot faster.

However, try the following, just to see if it changes the width. I would do one at a time.

.calendar-calendar {
  width: 300px !important;
}

Open in new window


.calendar-calendar .month-view {
  width: 300px !important;
}

Open in new window

.calendar-calendar .month-view table {
  width: 300px !important;
}

Open in new window


Try each of those and let me know how it turns out. Again, I would try one at a time.
0
 
riteloAuthor Commented:
I did both, but nothing is woking, unless I don't know how to reload a module.  ...Thanks
0
 
jonahzonaCommented:
What is the module you are using called?
0
 
riteloAuthor Commented:
The module name is Calendar.
0
 
jonahzonaCommented:
I am looking for a version that is live so i can try some live editing. Let me know if you have seen it in use elsewhere.
0
 
riteloAuthor Commented:
OK. It is with drupal 6... If I find a live version i will let you know.
0
 
jonahzonaCommented:
Found one.

This might work. The selector is a little different than the one I found.

view view-calendar view-id-calendar view-display-id-calendar_1 view-dom-id-1 {
 width: 300px !important;
}

Open in new window


Alternatively, you could wrap it in another div. I am not a drupal guy, but you could simply wrap your module in a div that you define.

#calendarwrap {
  width: 300px;
  height: auto;
  float: left;
}

Open in new window


Then drop your module inside of the wrap.

but try the first one first.
0
 
riteloAuthor Commented:
Do you want me to copy the code and paste it in my CSS?
0
 
jonahzonaCommented:
That first one, yes.
0
 
riteloAuthor Commented:
I added that code, uninstalled the module, re-installed it again but still not working...
0
 
jonahzonaCommented:
Sorry. This is tough working off of parsed code because it is possible I am missing something.

The code I gave you I edited on this site, and it worked:

http://demo.websitebeta.net/calendar

However, I don't think that I will be able to help further without a live version of the site.

Sorry.
0
 
riteloAuthor Commented:
Thanks...
0
 
junipllcCommented:
Just a few notes (from a Drupal guy) --

1- Don't modify the module itself or anything in the module's directory. You'll need to put the CSS into your theme's CSS file to override the part that's causing the problem.

2- Make sure you clear your cache when you make changes (not your web browser's cache, Drupal's cache) ... and make sure that your CSS aggregation is not enabled when you're developing. Those settings can be found under Site Configuration -> Performance

3- You don't have to uninstall the module and then re-install it, just put the new, overriding CSS code into your theme's CSS (which in your case is /sites/all/themes/court/style.css) -- just paste it at the bottom so it overrides everything above it. The theme's CSS is the last to load (typically) so anything in there will override everything before it.

4 - always, and I mean after every change if necessary, clear those caches. Caches are the bane of my existence, second only to IE. ;)

By the way, since I see you're using the Administration Menu module, to clear your Drupal caches just go to the top left menu (usually looks like a Drupal icon) and select "Flush all caches" -- simple shortcut.

Mike

P.S. There is a Drupal zone on E.E. -- you'll probably get much better results if you post there as well as here.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 9
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now