• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1922
  • Last Modified:

Exchange 2010 Autodiscover internal URL problem.

Hello,
We have an Exchange 2010 server, and we have encountered a problem when users that have office 2007 and they try to turn on Out of Office assistant.  Outlook returns the message" Your Out of Office settings cannot be displayed, because the server is currently unavailiable.  Try again later."   From what we have read so far, the problem likely lies in the autodiscover service.  When we performed the Test Email Autoconfiguration from an outlook client, it fails we look at the logs, it shows our external url, not our internal url.  Any gui interface we have looked at so far distinctly reflects the correct internal and external urls to the mail server.  What we need to know is how (likely in powershell) we can force the autodiscover service to pass the correct internal url, instead of the external mail url?
0
SpiderGoat
Asked:
SpiderGoat
  • 2
1 Solution
 
abhijitmdpCommented:
To resolve this issue, modify the URLs for the appropriate Exchange 2007 components. To do this, follow these steps:
Start the Exchange Management Shell.
Modify the Autodiscover URL in the Service Connection Point. The Service Connection Point is stored in the Active Directory directory service. To modify this URL, type the following command, and then press ENTER:
Set-ClientAccessServer -Identity CAS_Server_Name -AutodiscoverServiceInternalUri https://mail.contoso.com/autodiscover/autodiscover.xml 
Modify the InternalUrl attribute of the EWS. To do this, type the following command, and then press ENTER:
Set-WebServicesVirtualDirectory -Identity "CAS_Server_Name\EWS (Default Web Site)" -InternalUrl https://mail.contoso.com/ews/exchange.asmx
Modify the InternalUrl attribute for Web-based Offline Address Book distribution. To do this, type the following command, and then press ENTER:
Set-OABVirtualDirectory -Identity "CAS_Server_name\oab (Default Web Site)" -InternalUrl https://mail.contoso.com/oab
Modify the InternalUrl attribute of the UM Web service. To do this, type the following command, and then press ENTER:
Set-UMVirtualDirectory -Identity "CAS_Server_Name\unifiedmessaging (Default Web Site)" -InternalUrl https://mail.contoso.com/unifiedmessaging/service.asmx
Note This command is required only in an Exchange 2007 environment. This command no longer exists in an Exchange 2010 environment. Instead, the WebServices URL is used for this purpose.
Open IIS Manager.
Expand the local computer, and then expand Application Pools.
Right-click MSExchangeAutodiscoverAppPool, and then click Recycle.

Ref#http://support.microsoft.com/kb/940726
0
 
abhijitmdpCommented:
The above same process is also valid for exchange 2010.
0
 
spiderwilk007Commented:
I think with exchange you are going to have better luck just setting up an Internal DNS record for your email server that matches your external records. In my organization I created a new DNS domain of our external domain for example: "contoso.com" and then added records for "mail.contoso.com", "owa.contoso.com" and "autodiscover.contoso.com" and pointed them to our internal IP address. This should solve your problem also. Plus it makes the Web Outlook easier to use for your clients.
0
 
SpiderGoatAuthor Commented:
Thank you abhijitmdp, that seemed to do the trick. Thanks for the quick response.
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now