While connected to the vpn, internal names are not being resolved...sometimes?

Hello,
 This usually only happens with laptops that use different ISP connections while they are travelling. Mine does it once in awhile but I usually flush the dns. I've been reading a lot of posts on here regarding vpn and dns issues but I'm still trying to pinpoint where the problem resides.
Firewall: Fortigate
O/S: Windows 7
Problem: Internal names cannot be resolved
The Fortigate is setup to dish out DNS IP's to the incoming connection. Once connected I can ping the internal IP's. Internal server names cannot be resolved. ie Bringing up an internal webpage using http://myserver/default.aspx won't work but replacing 'myserver' with the IP works fine.
This seems to happen on certain cable ISP's. Rogers is a nasty one for doing this but Bell you would have no problem with. Do cable providers do something so that they force you to always use their DNS servers first? Is there a way to force my internal DNS servers to be used while connecting through the VPN? This is a pain!!

Thank all,
BW
bwinkworthAsked:
Who is Participating?
 
MikeKaneCommented:
Run an NSLookup while on VPN.  Make sure you are on the right dns server then enter the FQDN for the machine you want.    Do you get an IP back or an unknown?     Is the IP correct?

IF it's unknown, then check that an A record exists in your Zone for this machine.  

 
0
 
MikeKaneCommented:
When you are connected to the VPN, run 'nslookup' from the command line.   The nslookup should return the IP of the current DNS server you are using.    Is it the VPN's assigned Dns  or your own?    If it is your own, check to see if DNS is set statically in your Adapter IPv4 settings.   If it is, then the VPN's assigned DNS are not being applied, hence no resolution.  

That's my 1st thought anyway.

0
 
bwinkworthAuthor Commented:
Thanks MikeKane. I did some testing at home on my laptop (wireless) because I can reproduce the problem with it. On my desktop at home I have no problems remoting in to my computer here at work using the machine name.
When I connected to the vpn with my laptop I attempted to remote to my machine and got the 'Remote desktop can't find the computer "machinename".' error message. So I did an nslookup and it reported back the IP of the DNS server of my internal network at work which is what the Fortinet firewall does. When I did an ipconfig /displaydns it showed the FQDN of my 2 DNS servers and their IP's but other server names displayed 'Name does not exist' How can it kind of work but then not really? This has been eating at me for some time.

Thanks fella,
BW
0
Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

 
MikeKaneCommented:
When you try the connection, are you using just the name (i.e. "server"), or the fqdn (i.e. "server.domain.com").     The fqdn would use dns, just name might be using WINS which could be pointing to an incorrect box.  

0
 
bwinkworthAuthor Commented:
I'm using just the name of my desktop @ work. I went into the advanced properties of TCP/IP and on the DNS tab I put in the suffix of our domain so I'm going to try the connection again tonight and I'll let you know what happens.

BW
0
 
bwinkworthAuthor Commented:
Ok so Friday night I tried it with the suffix in the advanced properties DNS tab of the fortissl adapter (vpn adapter), logged into the vpn and remoted into my machine on the first attempt. I shut the laptop down for the night and tried it again on Saturday and it failed. This is all happening on wireless so I think tonight I'm going to wire in the laptop and see what happens and turn off the wireless. I just don't get it. ipconfig /displaydns shows all the right info. The 2 domain controllers show up but it did show the name of my computer in the list but it said 'Name does not exist' which is why I'm assuming it can't find my machine. It can ping it by IP but not by name.

BW
0
 
bwinkworthAuthor Commented:
Thanks Mike. I'll test that out tonight.

BW
0
 
MikeKaneCommented:
Any Luck?
0
 
bwinkworthAuthor Commented:
I tried last night. No problems. Got into my machine relatively quickly. Tried again this morning before I came into work...no problems. I can't break it again lol. The only thing I've done is put that suffix in a few days ago and it worked fine one day then didn't the next but I have rebooted. I'm taking home a freshly imaged laptop tonight and that will be my ultimate test. The nslookup last night reported my 2 dns servers as usual and then I typed in the FQDN of my machine at work and it reports back with the proper IP. Tonight will be my final test I guess.

BW
0
 
MikeKaneCommented:
OK then, good luck.
0
 
bwinkworthAuthor Commented:
Well I had no problems with a newly imaged laptop. I really don't understand why some laptops work without the suffix and others you need to put it in. Oh well I'll close this off and thanks for the help Mike.

BW
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.