We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Public Folders not replicating Exchange 2007 to 2010

Medium Priority
767 Views
Last Modified: 2012-10-24
We are migrating Exchange 2007 to Exchange 2010 and have ran into a problem with the public folders not replicating fully to the exchange 2010 server. Currently the exchange 2010 server has the hierarchy fully replicated and some folders but all of them have not came through. It has been over 24 hrs. I have turned up the event logging on both servers as well.

I will give you an example of what I have been working with. We will use the folder named "churches"

I have churches set on the "old" server to replicate to the "new" server and itself. On the new server I have that same folder set to replicate with itself (new server). It is not replicating.

Yesterday I ran the following powershell script

.\MoveAllReplicas.ps1 -Server "Exchange 2007 Server" -NewServer "Exchange 2010 Server"

This morning I noticed only a few folders actually replicated and most did not. I ran it again today with no sucess.

I have tried to force the replication by changing the folder properties to "always" replicate.

I have restarted the exchange services on both servers with no results.

Thanks in advance for any help!! =)

Comment
Watch Question

AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Do you see any event 3020 on source server?

Author

Commented:
Yes I will post the pictures. I only found it once. error description1 error description2
AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
It means source server is sending outgoing message. Now check on destination server event id 3030. Apart from this do you see

3014 on Source server
3024 on destination server

I suggest to give more time for replication. Is this over the WAN or LAN?

Author

Commented:
This is over LAN, I do see the 3030 on the destination server. I did not see 3014 or 3024 on the servers you listed.
AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
So replication is going on and you don't have any backfill. Give more time for replication to complete. It depends the PF data size.

Author

Commented:
Thank you very much, I will keep everyone updated.

Author

Commented:
This morning I still havent recieved any replication data. The folders are still empty. I did find this error in the event log with a few others..

 cderror3
AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Can you post new item to the folder and see if it replicates? Normally, i have seen, if you post new items it start replication. Try it.

Author

Commented:
ill try and update you. Thanks!
AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
This is one issue with PF. I didn't told you manual step, as it is long and tedious process, as u mentioned

Author

Commented:
Problem not even solved by Microsoft.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.