• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 759
  • Last Modified:

Public Folders not replicating Exchange 2007 to 2010

We are migrating Exchange 2007 to Exchange 2010 and have ran into a problem with the public folders not replicating fully to the exchange 2010 server. Currently the exchange 2010 server has the hierarchy fully replicated and some folders but all of them have not came through. It has been over 24 hrs. I have turned up the event logging on both servers as well.

I will give you an example of what I have been working with. We will use the folder named "churches"

I have churches set on the "old" server to replicate to the "new" server and itself. On the new server I have that same folder set to replicate with itself (new server). It is not replicating.

Yesterday I ran the following powershell script

.\MoveAllReplicas.ps1 -Server "Exchange 2007 Server" -NewServer "Exchange 2010 Server"

This morning I noticed only a few folders actually replicated and most did not. I ran it again today with no sucess.

I have tried to force the replication by changing the folder properties to "always" replicate.

I have restarted the exchange services on both servers with no results.

Thanks in advance for any help!! =)

0
Jryals8900
Asked:
Jryals8900
  • 7
  • 6
1 Solution
 
AmitIT ArchitectCommented:
Do you see any event 3020 on source server?
0
 
Jryals8900Author Commented:
Yes I will post the pictures. I only found it once. error description1 error description2
0
 
AmitIT ArchitectCommented:
It means source server is sending outgoing message. Now check on destination server event id 3030. Apart from this do you see

3014 on Source server
3024 on destination server

I suggest to give more time for replication. Is this over the WAN or LAN?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Jryals8900Author Commented:
This is over LAN, I do see the 3030 on the destination server. I did not see 3014 or 3024 on the servers you listed.
0
 
AmitIT ArchitectCommented:
So replication is going on and you don't have any backfill. Give more time for replication to complete. It depends the PF data size.
0
 
Jryals8900Author Commented:
Thank you very much, I will keep everyone updated.
0
 
Jryals8900Author Commented:
This morning I still havent recieved any replication data. The folders are still empty. I did find this error in the event log with a few others..

 cderror3
0
 
AmitIT ArchitectCommented:
Can you post new item to the folder and see if it replicates? Normally, i have seen, if you post new items it start replication. Try it.
0
 
Jryals8900Author Commented:
ill try and update you. Thanks!
0
 
Jryals8900Author Commented:
I called Microsoft and event they could not fix it. They told me the data must be corrupt. Ended up having to connect a machine to the old exchange server and grab public folder data by exporting pst files. After this I uploaded pst files into new server. Long and tedious but it saves approx 80% of the data.
0
 
AmitIT ArchitectCommented:
This is one issue with PF. I didn't told you manual step, as it is long and tedious process, as u mentioned
0
 
Jryals8900Author Commented:
Problem not even solved by Microsoft.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now