We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

CRM 2011 Reporting Extensions install Error: Reports will not be published for some organizations...

Medium Priority
6,478 Views
Last Modified: 2013-11-24
Trying to install Reporting Extensions with CRM 2011 Server using SQL Server 2008r2 with Windows Server 2008 R2.
 
Receive this error: "Warning: Reports will not be published for some organizations because the Report Server instances used by these organizations differ from the instance selected during Microsoft Dynamics CRM Reporting Extensions Setup."  Upon entering Deployment Manager it reports Reporting is not enabled and One or more server roles are missing from this deployment.  The proper URL for reporting services shows under properties for the organizaton.
 
A review of the SRSDCsetup log shows:
 
08:38:59|   Info| CrmAction execution time; CollectAction; 00:00:00.0156000
 08:38:59|   Info| CrmAction execution time; CollectAction; 00:00:00.0156001
 08:39:00|Verbose| Retrieving Base Language Id Provider=SQLOLEDB;Data Source=servername;Initial Catalog=CQcrm_MSCRM;Connection Timeout=60;Integrated Security=SSPI ...
 08:39:00|   Info| Base Language Id of CQcrm_MSCRM: 1033.
 08:39:00|Warning| Instance Name needs to be escaped. Management Exception: Invalid namespace
 08:39:00|   Info| Escaped Instance Name is RS_MSSQLSERVER
 08:39:00|Warning| Could not find a local RS instance corresponding to the reporting url https://servername.domain.local/reportserver for organization CapitalQcrm
 08:39:00|   Info| CrmAction execution time; CollectAction; 00:00:01.2012021
 08:39:00|Warning| Instance Name needs to be escaped. Management Exception: Invalid namespace
 08:39:00|   Info| Escaped Instance Name is RS_MSSQLSERVER
 08:39:00|   Info| CrmAction execution time; CollectAction; 00:00:00.1404002
 08:39:00|   Info| CrmAction execution time; ValidateAction; 00:00:00.0156000
 08:39:00|Verbose| Method entry: Microsoft.Crm.Setup.SrsDataConnector.SrsDataConnectorSetup.RunInternal
 08:39:01|   Info| Setup thread-routine provided to progress wizard
 08:39:01|   Info| ActivatePage(SqlServerPage)
 08:39:01|   Info| Window Left: 548
 08:39:01|   Info| Window Top: 308
 08:39:13|Verbose| Retrieving Base Language Id Provider=SQLOLEDB;Data Source=servername;Initial Catalog=CQcrm_MSCRM;Connection Timeout=60;Integrated Security=SSPI ...
 08:39:13|   Info| Base Language Id of CQcrm_MSCRM: 1033.
 08:39:13|Warning| Instance Name needs to be escaped. Management Exception: Invalid namespace
 08:39:13|   Info| Escaped Instance Name is RS_MSSQLSERVER
 08:39:13|Warning| Could not find a local RS instance corresponding to the reporting url https://servername.domain.local/reportserver for organization CapitalQcrm
 08:39:13|   Info| ActivatePage(SsrsInstancePage)
 08:39:19|Warning| Instance Name needs to be escaped. Management Exception: Invalid namespace
 08:39:19|   Info| Escaped Instance Name is RS_MSSQLSERVER
 
There is no option to name the Reporting Server instance.  We have a default install and in the Set up wizard are choosing the server hosting CRM/SQL. Everything is on same box.  SQL Reporting Service account  is member of PrivReporting and PrivUsers.
 
 
 
Tried config file:
 

<?xml version="1.0"?>
 -<crmsetup> -<srsdataconnector> <configdbserver/> <autogroupmanagementoff>false</autogroupmanagementoff> </srsdataconnector> </crmsetup>
 
with autogroup management on and off.  I have seperate service accounts for all functions in CRM and SQL.  CRM website is working and am able to import organization into it.  Just no reports.
 
Where do I go from here??
Comment
Watch Question

Feridun KadirPrincipal Consultant
CERTIFIED EXPERT

Commented:
Is Reporting Services installed in the default instance of the SQL Server? Or are you using a named instance?
The error messages seem to be complaining about the reporting services server name which might be to do with the server name, instance name or the url.

I would uninstall Reporting Extensions, verify that reporting services is working (browse to the report server in IE), verify all names are ok and then install Reporting Extensions.

Author

Commented:
Reporting services is installed as the default.  I can browse to ReportServer and see the CRM organization folder.
Feridun KadirPrincipal Consultant
CERTIFIED EXPERT

Commented:
What about the names used for the computer and the URL?

Author

Commented:
I can navigate to the URL as shown in the Deployment Configuration for the Organization.  Works with no issues.
Chinmay PatelChief Technology Ninja
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Hi erm4,

Have you checked this KB?

http://support.microsoft.com/kb/947060

Regards,
Chinmay.

Author

Commented:
Yes to no avail.
Feridun KadirPrincipal Consultant
CERTIFIED EXPERT

Commented:
Do you have other reporting services instances on your server that are not fully configured? If so, then this post may be of relevance.

Author

Commented:
There is only one instance of Reporting Server running.
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Author

Commented:
self source solution
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.