• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1497
  • Last Modified:

ssis precedence contraint connector line not anchoring straight (cosmetic)

Hi,

Inside a sequence container that has multiple tasks, after connecting the tasks with a straight, centered precedence constraint, saving then reopening the package will invariably have 1 or more lines that are no longer straight.

Is there a known trick that anchors a straight connector line?  

Thank you!

 before and after saving a package
0
ssebring
Asked:
ssebring
1 Solution
 
ValentinoVBI ConsultantCommented:
Hmm, that's weird, I don't really remember this happening.  Though I'm working with team members who sometimes forget to align the objects so maybe I just never noticed this "feature" before.

Maybe try resizing the SQL tasks (enlarge them just a little), re-align, save and open, see if that solves the cosmetic issue?
0
 
Alpesh PatelAssistant ConsultantCommented:
It doesnt make any difference in your logic or functionality.
0
 
8080_DiverCommented:
It is, indeed, a cosmetic thing and that bugs me, also.  There are a couple of options:
1) Move the top of the connection to the middle of the bottom of the top box (how's that for convoluted ;-);
2) Make sure that the top boxes being connected are of the same size and are aligned (and, even then, you may need to tweak their location slightly to get the connectors to be straight ;-).
0
Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

 
ssebringAuthor Commented:
thanks for the replies!

Valentino -- Yes, tried mucho ways of resizing, aligning, placements prior to posting... thanks for the comment though.

Patel -- you are correct, my question is a cosmetic, not logic or functionality issue.

8080 -- thanks for the agreement!  Have tried many things, nada.  Didn't entirely understand your #1 suggestion, does the screenshot (before pic) represent what you are saying on that? (#2 suggestion, feel I've exhausted moving, sizing & aligning attempts).
0
 
8080_DiverCommented:
Yes, the first screen shot represents the results of suggestion #1.  (And, yes, I get frustrated with Microsoft's screwing around with what I have on the screen before saving it! ;-)  

I am trying to get my employer to buy at least one license of BI-Xpress so that I can use it to make my life easier with regard to several aspects (including better placement of components) of developing  in SSIS.  I don't know if some of the features of that tool will address this particular quirk in BIDS , though.

I have even gone so far as to start a new project and to copy components across to it in order to get things to align and stay aligned. :-/

To my way of thinking, it is kind of like what Microsoft does to the formating of SQL statements.  It is much easier to read both an SSIS package and SQL statements if they are decently formatted.  Microsoft screws around with both of those and totally messes with formatting on many occasions.
0
 
ssebringAuthor Commented:
haha! yes! terrible 101 stuff. SSIS sql task editor is a mess when it comes to sql formatting (or lack of).

Thanks for the suggestion on BI-Xpress -- will check into it.

In defeat, going to go ahead and accept your last post as the final answer...  

thx again for the replies!

0
 
FrancoisVermeulenCommented:
Hi!

I struggled with this for a while, even had some sleepless nights being OCD about "Package Polish".

What I found worked for me was to enable the Layout Toolbar in BIDS - you can do this through the file menu by selecting View—>Toolbars—>Layout

From there, highlight all the objects in your package, the hit the Align Centre button.

Another more cosmetic method is to highlight an object and use the CTRL + <cursor> to align the precedence constraint.

A final tip is to enable the precedence constraint labels. For you need to go into the file menu in BIDS (Tools—>Options—>Business Intelligence Designers—>Integration Services Designers) and check the box ‘Show precedence constraint labels’ in the Accessibility section.

I credit this information to a blog I read previously,
http://denglishbi.wordpress.com/2009/02/01/integration-services-ssis-package-designing-tips/
.

Hope this helps.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now