• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 8334
  • Last Modified:

XenApp 6 Cannot contact Licensing Server

Setup
Located in CT office:
Server name MT-CIT
-Windows 2008 R2 (no SP1) (non DC) -
   XenApp 6 Platinum Edition
   XenApp Licensing Server
   XenApp Web Interface

Server Name MT-FILE
-Windows 2008 SP2 (DC)
   File Server

Located in NY office:
Server Name NY-FILE
-Windows 2008 R2 (no SP1) (DC)
Group Policy and A/D is handled here

I have installed XenApp 6 Plantium edition and setup Calculator as a test app.  XenApp, License Server and Web Interface is installed on MT-CIT server.  I have setup the license server on port 27000 (default port) and retrieved my license keys, applied them in the server.  I see them and XenApp recognizes the keys.
In Citrix Delivery Services Console, XenApp, MTCITRIX, Policies - I entered the server name license server host name MT-CIT, License Server Port as 27000.
Everything was working until I rebooted the server.  At the Windows login prompt I enter my password and get the following error: "Citrix XenApp cannot contact the licensing server Empty".  Which now I cannot connect the XenApp server and access my apps.  That error, to me, means that no license server is specified?
Event viewer shows Event 9017, MetaFrame This computer running Citrix XenApp will now stop accepting connections.  This server is no longer in or could not enter a licensing grace period.

What I've learned is Citrix uses Group Policy and can integrate (or use with) into Windows Group Policy.  When I load group policy on MT-CIT, I see a folder for Citrix but when I load Group Policy on NY-FILE I don't see a folder for citrix.  Correct me if I'm wrong by Citrix is not in the A/D policy thus the MT-CIT policy is getting overwritten (as it should be).

When I go back into the Citrix Delivery Services Console Policies, nothing is changed and the License Host and Port are still as I had entered them.  gpupdate /force doesn't seem to work.
0
Chip1035
Asked:
Chip1035
  • 8
  • 8
  • 3
  • +2
1 Solution
 
Carl WebsterCommented:
Delivery Services COnsole on MT-CIT
Policies
Computer Unfiltered
License server host name
License server port

Set those two, exit DSC and reboot the server.
0
 
Chip1035Author Commented:
My apologies if I wan't clear but that is what I did already.
0
 
Carl WebsterCommented:
OK, you didn't say of the Policy was the unfiltered one or not.

If you do a qfarm /load is the load value 20000?
0
Fill in the form and get your FREE NFR key NOW!

Veeam is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 
Carl WebsterCommented:
0
 
basrajCommented:
Restart the Citrix license server and see if the licensing service is running. After that reboot the Presentation server and check
0
 
kmkingCommented:
We had the same problem when the license server kept having the daemon stop. Restarting the service resolved the issue, however it would continue to happen. There is still not a public release of a hotfix for this issue.

Also if the license server was installed on a VM and was abruptly stopped it can cease to function. Reinstallation of the license server will also correct this.

Backup your license files and just reinstall and see if that helps.

Also, if you can I would suggest putting your license server off the WI boxes. I want to think this is something Citrix will recommend as well, seperate WI and License servers
0
 
Chip1035Author Commented:
Carl, I've tried the link you gave me.  The hotfix is not available to me because we do not have a support contract/agree/etc.  The workarounds haven't worked.
I was able to reach Citrix for support because they provide support for licensing issues.  The rep had me re download my license and reapply my licensing.  It work but again only for a a little while and then the server would lose the licensing and we cannot connect.

I'm at the point I feel like uninstalling everything and reinstall it.  Maybe I'll try uninstalling the license portion only and install the license server on the server in NY.
0
 
Carl WebsterCommented:
email me and I can send you the hotfix.  webster@carlwebster.com
0
 
Chip1035Author Commented:
Still troubleshooting this error.  Applied fix Carl sent me but still receiving the error.
0
 
kmkingCommented:
Is this the hotfix that puts your license servers at version level 11.9 and not 11.6?
0
 
Chip1035Author Commented:
I'm showing it's still 11.6
0
 
Carl WebsterCommented:
You may need to contact Citrix support to get the updated license server version they have.  It is not available even to me without calling support.  Sorry.
0
 
kmkingCommented:
the 11.9 is a private build, but this was supposed to be released already from what I understand. It deals with some daemon crashing along with some other issues.
0
 
Carl WebsterCommented:
11.6.1 build 10007 has issues with XenApp 6.  There is a build 11.6.1 build 10009 that is available from support.  11.9 is under NDA.
0
 
Chip1035Author Commented:
If that's the case, I may just throw in the towel and spent the $500 (or whatever it is (also pending my manager's approval)) for the one time support.
I called and got support for the licensing but they don't know anything about any other build other than what's available on the general website.  If anyone has any other suggestions, I welcome them.  I do appreciate the help so far.  Thanks...
0
 
Carl WebsterCommented:
If they charge you for a bug fix, I would raise high holy hell with them!!!
0
 
Chip1035Author Commented:
Something with Windows occurred.  Decision has been made to rebuild the server which is planned for Monday.  I'll let you know if I continue to have the issue on the rebuild.
0
 
Carl WebsterCommented:
If the issue happens again, Friday the 13th may be your lucky day.  Don't ask cuz I won't (and can't) say why.
0
 
Chip1035Author Commented:
I rebuilt the server due to an Windows error.  Being a non essential server doing nothing but host Citrix, it was decided the error would best serve rebuild instead of troubleshooting.  I won't go into much detail as it does not pertain to the question I posted.

Since the rebuild and reinstalling Citrix, the error seems to have not come back.  Cross my fingers.
0
 
Chip1035Author Commented:
I broke and purchased the Software Maintenance package.  Not bad price for one year, less than the price of a one time fee and I get 5 requests.  Citrix is currently looking into the issue.  Must be a big one.  They were remotely logged in for 3 hours yesterday and haven't finished.  Continuing work today.
0
 
ee_autoCommented:
Question PAQ'd and stored in the solution database.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 8
  • 8
  • 3
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now