• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 718
  • Last Modified:

Exchange 2007: Mail submission failed: Error message: The SMTP host was not specified.

I'm getting an error when runnign the Mailflow troubleshooter in Exchange 2007.  I'm also running Exchange 2003 currently (although I plan on removing it once I get 2007).  I have checked everything I can find.  The one thing to note is that I don't have the public IP entered in my NIC settings yet (waiting to get one mailbox working internally...hopefully if it's even possible?)  I can send mail using a given account that we'll call News.  But I can't receive mail in News.  I tested this morning but turning our 2003 server off and adding in the public IPs, but then I could receive, but not send.  I've tried everything i can find.  I can telnet on port 25.  I think it's going to be something simple and a one click change....just can't figure it out.  Thanks!
Bridget
0
bridgetimiller
Asked:
bridgetimiller
  • 2
1 Solution
 
Delphineous SilverwingGood Ol' GeekCommented:
Microsoft changed the way Windows uses multiple addresses.  Your issue may be being caused by this if you are using Windows 2008/2008r2
http://blogs.technet.com/b/networking/archive/2009/04/24/source-ip-address-selection-on-a-multi-homed-windows-computer.aspx

If the option is available, it may work better for you to setup a network address translation (NAT) in your firewall for the server and then only have the private IP in the server.
0
 
bridgetimillerAuthor Commented:
The problem ended up being that I had installed the SMTP service on the  new mail server, since the old one had it, which was confusing Exchange.  After about 48 hours on the phoen with microsoft, they finally figured it out.  
0
 
bridgetimillerAuthor Commented:
Giving myself the points, since I figured it out without Experts help.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now