SharePoint Workflow - Workflow Starts multiple times

Posted on 2011-04-27
Last Modified: 2012-05-11
I have a workflow created in SharePoint designer that starts every time the document is changed even though the option to start on change is de-selected. The workflow is attached to a forms library that uses an InfoPath 2007 template.

The workflow seems to function properly, but I'm getting an email (which is in the first step) every time a change is made to the document which is not acceptable. I tried manually changing the xml to be false, but the designer deletes it when I save, although the default is supposed to be set to false.

It's driving me nuts, any help is appreciated.
Question by:nsi07
    LVL 3

    Expert Comment

    The workflows will only start on creating a item?
    Does InfoPath start the workflow also?

    How many times does the workflow start?
    If the workflow runs on change and it changes the item, it will run again. Check if this happens.

    Accepted Solution

    Thanks for the reply.

    It SHOULD only start on item creation, but it keeps starting every time an item is changed evn though the only checkbox I have selected is the Start on Item Created in the workflow options. I ONLY want it to run once but it runs every time the item is changed so It's sending multiple emails.

    I have the Run On Change NOT selected, but it starts the workflow every time the item is changed and I can't understand why.
    LVL 3

    Expert Comment

    Try to delete the workflow and recreate it. Are there other workflows in the list? Maybe they trigger the workflow to run... Can it be solved with the mail function in InfoPath? InfoPath can also mail users when a form is filled in... Kind of work around...

    Author Comment

    I will look at using infopath methods to send the emails as despite creating multiple instances, the workflow does properly "move" the item through the steps. I have recreated the workflow and have the same issue, but the InfoPath mail might be a decent work-around.

    Author Closing Comment

    The issue was actually with the InfoPath template when I investigated using your work-around I found it.

    Thanks for the help!

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Top 6 Sources for Identifying Threat Actor TTPs

    Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

    Suggested Solutions

    If you create your solutions on SharePoint sooner or later you will come upon a request to set  permissions of the item depending on some of the item's meta-data - the author, people assigned as approvers, divisions, categories etc. The most natu…
    Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
    This video is in connection to the article "The case of a missing mobile phone (". It will help one to understand clearly the steps to track a lost android phone.
    In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor ( If you're interested in additional methods for monitoring bandwidt…

    737 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    20 Experts available now in Live!

    Get 1:1 Help Now