disable rpc.statd service

I want to disable the rpc.statd services running on the system as it is one of the vulnerability that needs to be closed. Actually in /etc/inetd.conf it is commented out but still it is working. Also i want that it should not start at boot up of OS. I am using solaris 9.

thanks
virgo
virgo0880Asked:
Who is Participating?
 
Joseph GanConnect With a Mentor System AdminCommented:
You can rename /etc/rc2.d/S71rpc to something like disabled.S71rpc.
0
 
Joseph GanSystem AdminCommented:
The package contains rpc.statd is "SUNWrcmds".
0
 
virgo0880Author Commented:
I dont want to remove it, i want to disable it. Is that possible only that service ?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Joseph GanSystem AdminCommented:
You can "kill" the process "rstatd", or try

/etc/rc2.d/S71rpc stop

I don't have a server can test it, because they all been disabled.
0
 
virgo0880Author Commented:
but I also want it not to start during startup of system ?
0
 
virgo0880Author Commented:
Ok, I will try that tomorrow on my test system. But this should disable only rpc.statd and not other nfs or rpc related services. Is it ?
0
 
Joseph GanSystem AdminCommented:
You can look the contain of the script, modify it if needed.
0
 
virgo0880Author Commented:
ok
0
 
Brian UtterbackPrinciple Software EngineerCommented:
What vulnerability does it have that isn't patched? If you are using NFS, you need rpc.statd running.
0
 
virgo0880Author Commented:
I will share the vulnerabilties details.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.