We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Exchange 2003 error running eseutil -1003 jet_errinvalidparameter

Medium Priority
2,117 Views
Last Modified: 2012-05-11
All I was trying to do was to defragment both priv1 and pub1 databases. I ran the same process on the server about a year ago. All was fine back then. Server has SP2 installed.

I dismounted both stores and started with the public.
I ran eseutil /g pub1.edb and it ran fine
Next I ran eseutil /p pub1.edb and it came back with an error message which I didn't write down.
I reran the same line again and now I get the following;
D:\Program Files\Exchsrvr\mdbdata>eseutil /r pub1.edb -s pub1.stm
~~~~~~~~~~~~~~~~~~~~
Microsoft(R) Exchange Server Database Utilities
Version 6.5
Copyright (C) Microsoft Corporation. All Rights Reserved.

Initiating RECOVERY mode...
    Logfile base name: pub1.edb
            Log files: <current directory>
         System files: pub1.stm

Operation terminated with error -1003 (JET_errInvalidParameter, Invalid API para
meter) after 0.0 seconds.
~~~~~~~~~~~~~~
File: d:\Program Files\Exchsrvr\mdbdata\pub1.STM
ERROR: database was not shutdown cleanly (dirty shutdown)


Operation terminated with error -550 (JET_errDatabaseDirtyShutdown, Database was
 not shutdown cleanly. Recovery must first be run to properly complete database
operations for the previous shutdown.) after 5.375 seconds.
~~~~~~~~~~~~~~~~~~~
I can also see that the pub1.edb and stm files have different time stamps
Need some help here
thanks
Comment
Watch Question

Author

Commented:
Forgot to mention that I updated the boot.ini with the following;
/3GB /USERVA 3030
but did not fix the issue
BusbarSolutions Architect

Commented:
the userva has nothing to do. the DB is in dirty shutdown, here is a link how to recover it.
http://www.mikepfeiffer.net/2010/04/getting-an-exchange-database-into-a-clean-shutdown-state-using-eseutil/
Viral RathodConsultant

Commented:
You want to run offline defrage then why you are running eseutil /r ?

The correct syntex for offline defrage is eseutil.exe /d "C:\Program Files\Exchsrvr\MDBDATA\priv1.edb"

I would suggest you to ................

1) First thing you need to look is if you really need a defrag
Check the Event Id 1221 on the Mailbox Store and Public Folder store to make sure sufficient white space is avilable on the database

White Space (Recyclable Space) indiactes how much space could be recovered by an offline defragmentation

White Space (Recyclable Space) means Exchange has carried out some routine maintenance on the Exchange database. Any old data that is past the delete thresholds has been deleted from the database.
The space it has left behind has then been consolidated, in to "white space". The size of the database hasn't changed - there is just some space within the database
http://www.msexchange.org/articles/Exchange-Databases-Disk-Consumption.html 

2) Check the Event Id 1216 on the Mailbox Store and Public Folder store to check  the Database Size

3) Make sure you have taken the complete Backup of Both the Exchange Database

4) Exchange offline Defrage Require 110% of Free Space to Defrage Exchange Store ,
If Mailbox Store Database size is 60 GB then you need atleast 70 GB of free disk space on the server
(Check Event Id 1216 for Database Size)

5) Make sure you have taken sufficient Down time to run offline defrag on exchange database
(4GB of Database Defrage Require 1 Hour to Complete (60 GB of Database Require Approx 15 Hours)

Refer the Article for Offline Defrage
http://technet.microsoft.com/en-us/library/aa998863(EXCHG.80).aspx
http://exchangeis.com/blogs/exchangeis/archive/2007/03/26/eseutil-a-quick-and-easy-tutorial.aspx

Author

Commented:
eseutil /r /l /d  is the command that I'm stuck on
there is an E00.log file in the d:\program files\exchsrvr\mdbdata
can you help with the command line?

Author

Commented:
I ran the repair by acident, just following my notes from a previous repair.
Consultant
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Author

Commented:
Ok, this is what I did to get the public folder running
renamed the pub1.stm to .old
eseutil /p /createstm pub1.edb
I was able to remount the file. I'm not sure if I've lost any data. What is the likelyhood?

Ok, I guess I'm back to square one but I would still like to know how I can fix this problem
BusbarSolutions Architect
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.