We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

PXE-E53: No Boot filename Received

arousek
arousek asked
on
Medium Priority
10,573 Views
Last Modified: 2012-05-11
Hi I need some help with WDS.

I am creating WDS in a test LAB environment and have installed everything successfully. I have DHCP and WDS running, however i cannot get PXE client to load. I get error message " PXE-E53: No Boot filename Received". Got this working the other day but now says that.

Can some one give me step by step troubleshooting instructions please. Ive seen some instructions in Google how to troubleshoot this but its not clear.

Thankyou.
Comment
Watch Question

Commented:
Hi,

please check if you still have a boot image.
Check Windows Deployment Services -> Servername -> BootImage

Is the machine you tried to PXE boot 32 or 64bit (CPU), you need to have a 32bit WinPE for an PC that has only 32bit CPU.
If you have only 64bit WinPE in WDS then you have to import a second 32bit BootImage from lets say a Windows 7 32bit DVD, it is in the sources folder i think
 

Author

Commented:
Hi I have 64bit R2 WS2K8 installed.  The boot files (boot.wim) are loaded and I have also added the install.wim files and they are 64bit version

Commented:
Ok, but the client that you want to PXE boot is it also 64bit?

Author

Commented:
yes thats correct

Commented:
Ok, does this happen only with that PC?
Tried an other computer?
Or add a 32bit Bootimage and try again.

Author

Commented:
I am using server 2008 with DHCP and Active Directorry installed.  It worked once before but i cannot get it working now.  I had both 32bit images and 64bit images installed

Commented:
Hmm, then i would fire up wireshark or network monitor and have a look at the network

Author

Commented:
I read on other forum that said something about the 066 and 067 parameters that need to be set in your DHCP server anyone know how to configure this


CERTIFIED EXPERT

Commented:
This error is a PXE error, that the PXE rom code created. At this stage, it does NOT matter if you have a correct image to deploy. I am not an expert in WDS but I am an expert in PXE.
And I am pretty sure that WDS uses a 32bits PXE-boot program, so at this stage, it should not matter if you want to use a 32 or 64bits environment.

Now regarding the dhcp options 66 and 67:
If your WDS service runs OK, you must NOT configure dhcp option 66 and 67:
These are for instructing the PXE *ROM* where to find the boot-file (on which tftp server, aka next-server, is it stored? This is option 66) and what is the name of that file (option 67).
WDS service is supposed to provide these details "the PXE way". And not the "DHCP way", which is to use dhcp option 66 and 67 or the special fields "filename" and "next-server", which come from bootp and are still valid with DHCP.

One question: Is your DHCP service and the WDS service running on the same server?
If on the same server, there MUST be a dhcp option 60 set for your clients, and this option must be set to "PXEClient" (case sensitive, without quotes).
If not on the same server, there must NOT be a dhcp option 60 for your client(s).
Check my article:
https://www.experts-exchange.com/Networking/Misc/A_2978-PXEClient-what-is-it-for-Can-I-use-PXE-without-it.html


I would recommend to check the following:
- WDS service is actually running and your client(s) can connect to it (bound to the correct NIC. You may use netstat -ba and see what address and port it has bound to)
- There is no "rogue" dhcp service on your network
- There is no rogue PXE service on your network that would not be correctly configured.

As L0n3W0lf mentioned, a network trace (Wireshark or MS netmon) might give us some better idea.
If you provide us such a trace, please filter on UDP, port 67, 68, 69 and 4011 only (and maybe on the MAC address of your client too, to avoid DHCP/PXE/TFTP pollution)

Author

Commented:
I reinstalled everything today.  clean server 2008 R2 with DHCP services running on same machine.  I installed WDS as well.  Now i get a new error:

PXE-E55: ProxyDHCP service did not reply to request on port 4011



Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION
CERTIFIED EXPERT

Commented:
I don't think this is very fair toclose this question in regard to the time we spent on it.
We did not have enough details to solve your case.


Anyway, thanks for sharing the details about how it was solved. THAT is fair.

PS: Regarding this
"arousek:
I reinstalled everything today.  clean server 2008 R2 with DHCP services running on same machine.  I installed WDS as well.  Now i get a new error:

PXE-E55: ProxyDHCP service did not reply to request on port 4011"

This is clearly because there was a dhcp option 60 set to "PXEClient" but no service answering on UDP 4011 on the server that also runs the DHCP service.


Author

Commented:
I did some futher tests, and reinstallled  WS2K8 R2 with DHCP and WDS on a new pc.

And this time i did not receive any problems at all .

I think maybe was also some hardware issues such as NIC card on the other PC.

If other people read this and got same problems as I did.  This could also be an issue for u
CERTIFIED EXPERT

Commented:
A hardware issue would be a very odd reason for these errors.
It can happen, but from my testing with PXE (literally several millions of PXE boot sessions), it happens very rarely and, when it does, it is usually that the client does not receive any packet. It never ended in one of the PXE error messages you reported.
Of course, some errors on your DHCP/WDS server (or on the switches) could cause some packets to be lost or not sent, but even this is very unlikely to happen and to cause the issues you've seen.
DHCP and PXE mechanism, even if they use UDP, are made so that there is some resilience to packet loss.

From what I read regarding your issue in EE and on whirlpool.com.au, I think that you may have another issue. Such as the things I recommended you to check:

- WDS service is actually running and your client(s) can connect to it (bound to the correct NIC. You may use netstat -ba and see what address and port it has bound to)
- There is no "rogue" dhcp service on your network
- There is no rogue PXE service on your network that would not be correctly configured.

A network trace for the traffic on UDP 67, 68, 69 and 4011 would have told you (us) EXACTLY what was happening...

Now since it seems that you are not able to reproduce the issue, it seems also that you can't reproduce its fix and that this question should not be closed for this reason !

Anyway, I won't object anymore to its closing, unless there are new posts in it.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.