• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1696
  • Last Modified:

Citrix Xenapp Plugin - Server Site Configuration

Hi there,

We're running Citrix Presentation Server 4.5 within our organisation.

Recently we encountered some problems which completely spiraled (caused by internet explorer) which ended up in Citrix being reinstalled completely over the weekend.

Everything is pretty much back to how it should be, with the intention of using the program neighbourhood to run most programs. However, this removes the "seamless" side of Citrix which we do require for a couple of users and I have been attempting to restore this functionality to no avail.

I have created the PNAgent site and configutred it for Gateway Direct with the correct STA.

When attempting to connect using a XenDesktop client on another machine, I receive the error:

"The remote server failed to execute the application launch request. Please contact your administrator for further details"

Followed by:

"Citrix XenApp could not contact the server. Please check your network connection"

Now, Citrix Program Neighborhood works just fine so the server is clearly functioning properly so I am guessing that the problem lies with the security configuration...?

I'm not totally clued up on this are of Citrix so I'd appreciate some help if at all possible (I'm sure theres an awful lot of things to check!)
0
ultra-it
Asked:
ultra-it
  • 2
  • 2
3 Solutions
 
kmkingCommented:
May try to define the IP of the DDC in WI rather than a FQDN and see. It may be far fetched, but it almost sounds like it is not able to talk to your defined DDC in the farm configuration on Web Interface. This happens to us if we lose our DDC that is defined there, or if you have more than one set and dont have it set to load balance them.
0
 
ultra-itAuthor Commented:
I've solved this one now, but thankyou for the advice. I have overlooked the Port number of the site, I had configure it to be 80 when all of the other sites (Internal/External) were configured with 8001.

Once I entered the correct port, all was fine and dandy.

Not sure how to sort points on this one though....
0
 
kmkingCommented:
No worries, most important thing is you solved the issue. I had the same type of problem and it boiled down to not being able to talk to the defined DDC in farm config.
0
 
ultra-itAuthor Commented:
I think its fair to say both are viable solutions, along with many others involving this area of Citrix. Hopes the distro of points is OK?
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now