• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 460
  • Last Modified:

GPO software deployment looping

I have a group policy that is used for application deployment(till we move away from it).

We had to redeploy Office standard instead of office 2007 Pro Plus.

Over the years of doing this, the steps Ive taken were:
- remove app from GPO(immediately uninstall option)
- Add new application
- reboot workstations and everything works as expected

Today, after performing the above steps, Office 2007 uninstalls and re-installs everytime the workstations reboot.

When I run rsop.msc on a workstation, it displays two deployments of Office; Office 2007 Pro Plus and Office 2007 Standard.

in my App deployment GPO, only Office 2007 Standard is listed, as expected.

I need some assistance trying to remove this ghosted app that continues to re-deploy.

There is a settings file I found in "\\corp.myDomain.com\sysvol\corp.myDomain.com\policies\{2ED536C0-9A51-42B0-9FE4-2216FB4967ED}\Machine\Applications" named {CE5D7573-CE16-4FBE-AC7B-125145A31C05}.aas

If I manually delete this file will this stop the redeployment of Office 2007 Pro plus that I no longer wish to have deployed?
0
nappy_d
Asked:
nappy_d
  • 3
1 Solution
 
Joseph MoodyBlogger and wearer of all hats.Commented:
Do you have the two office installs in two separate GPOs?
0
 
nappy_dAuthor Commented:
No they are in a single GPO for all app installs
0
 
ashutoshsapreCommented:
To test, instead of removing/deleting that file just rename it and see if it helps.

Also why don't you try silent uninstall of Pro and silent install of standard edition? Just configure the .xml file for Pro and standard and create batch file (which first uninstalls the Pro edition and then installs the standard edition) and add it to the startup scripts in group policy.

Silent Uninstall of Office 2007

Configure a silent install of the 2007 Office system with Config.xml

0
 
nappy_dAuthor Commented:
No renaming did not make a difference.

I didn't do that because in the past 7 odd years I have been sng AD, the bove steps I outlined has worked on hundreds of machines and about 60 or so various apps over the years.  I saw no reason to use another method when this worked and worked well.

Any one have any other thoughts on a resolution?
0
 
nappy_dAuthor Commented:
Turns out someone somewhere had changed the permissions on the OU which was preventing the computers from reading any of the GPOs
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now