?
Solved

VisualSVN - Repository is not available

Posted on 2011-04-28
11
Medium Priority
?
1,927 Views
Last Modified: 2013-11-13
I have installed VisualSVN Server (standard) on a server.  I've also installed VisualSVN client (and TortoiseSVN).  I have a solution in VS 2010 that I want to add to the server.  

I am getting an error that the "Repository is not available. Request was failed with the following message: OPTIONS of 'https://<my server ip>/c/svn/CMS': 200 OK"

I have tried creating a new repository on the server from the client, and I've tried creating the repository on the server itself and then updating it from the client with my solution in VS.  

I thought it was perhaps the port (443), but that port is available.  Port 8443 is in use by PLESK.

Any ideas why I can't access the repository?
0
Comment
Question by:bjones8888
  • 6
  • 5
11 Comments
 
LVL 9

Expert Comment

by:crazedsanity
ID: 35492514
In past experience, I believe I got that rather non-useful message from the SVN server when there was a permissions problem.  I'm not exactly certain what to check, but that should at least get you started.
0
 

Author Comment

by:bjones8888
ID: 35492718
You may be onto something.  I don't know how subversion handles user credentials, so I'm reading through the TortoiseSVN help manual (which I should have done before now).

At no point has it asked for login credentials. I have created users with passwords on the server, but haven't set up login info on the client.
0
 

Author Comment

by:bjones8888
ID: 35493597
This is driving me absolutely nuts!  Can't see what I'm doing wrong.  I'm having difficulty figuring out whether the problem is "subversion", "tortoisesvn", or "visualsvn"!!!!!

Surely there is someone I can get to assist me with this setup!?  I bet that someone who has been through this before can webex to my server/pc and have it straightened out in a short order.  Anyone know where I can get that type of support?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
LVL 9

Expert Comment

by:crazedsanity
ID: 35493815
I can almost guarantee that the problem resides with the server or repository, not any of the clients (like tortoisesvn).  If you've installed an hook scripts, try disabling them to see if that fixes the problem.  Do you have other repositories that are working on that server?
0
 
LVL 9

Expert Comment

by:crazedsanity
ID: 35493832
At what point are you getting the "200 OK" message?  Through the server VisualSVN interface, is there any data in the repository?
0
 

Author Comment

by:bjones8888
ID: 35493872
I have no repositories (other than one blank test), and no hook scripts.
0
 

Author Comment

by:bjones8888
ID: 35493920
If I try to connect to "https://<my server ip>/c/svn/CMS" - I get "could not connect to server".

If I try to connect to "https://<my server ip>/svn/CMS" - I get a 501 Not implemented error.  

I am no longer seeing the 200 OK error (and I don't know why).
0
 

Author Comment

by:bjones8888
ID: 35493941
On the server, I have the VisualSVN server process running.  I don't have SVN Server, or Tortoise, if those are required.  This server has a port conflict with 8443, so I've changed the port assignment to 7443.  Do I need to change anything on the client?
0
 
LVL 9

Accepted Solution

by:
crazedsanity earned 2000 total points
ID: 35493951
Using your browser, go to the repository's URL.  You should see a VisualSVN page listing repositories or the contents of repositories.  I ran a quick test, and it seems that specifying the wrong URL returns the "200 OK" response.

Go into the VisualSVN interface.  Expand "Repositories", right-click on your "CMS" repository, and select "Browse"  It should open the URL in your browser.  That should ensure the URL is correct.
0
 
LVL 9

Expert Comment

by:crazedsanity
ID: 35493963
I'm not sure what ports 8443 and 7443 are being used for... can you explain?  How did you determine there was a port conflict?
0
 

Author Comment

by:bjones8888
ID: 35494151
Success!!

VisualSVN Server setup uses 443 or 8443 if you select "Secure SSL".  My server has another program using 8443, so I changed the port to 7443.

the correct browser syntax is "https://<my server ip>:7443/svn/CMS" - where I have to put the port number before "/svn/CMS".  This time it prompted me for user and password.  After entering that, I got a "403 Forbidden" error.  that was because I hadn't added my user account to the test repository.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
If you are a mobile app developer and especially develop hybrid mobile apps then these 4 mistakes you must avoid for hybrid app development to be the more genuine app developer.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question