Silverlight installation fails

On windows 7 64-bit OS, I tried to run netflix the other day but for the first time ever, it told me to download Silverlight. I did, but it errored out at 99% installation with error #1603. I also tried installing a Silverlight update, but that failed as well. Ideas? Thanks.
jwagmanAsked:
Who is Participating?
 
vbighamCommented:
Is there a SilverlightMSI.log file located in your temp folder?  (C:\TEMP\SilverlightMSI.log)

That may give you the real error message, that or the windows event viewer might have an entry?

Also, does Microsoft Silverlight show up as an entry in Programs and Features?  If it is still in there even after a failed install, I wonder if you have come across this blog about cleaning up a failed installation:
http://blogs.msdn.com/b/rpomeroy/archive/2008/06/10/how-to-manually-clean-up-a-bad-silverlight-installation.aspx

It sounds like I am on a similar system Win7 64bit IE9 and I don't see that registry key either.  I do see HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\MAIN\Feature Control\FEATURE_ENABLE_SCRIPT_PASTE_URLACTION_IF_PRESENT  I don't know if that is the same thing or not, I don't think it should hurt to add yourself as full control for that key, but I don't know if that will work.

Other than that, I'm not sure what else to check but maybe UAC. If your User Account Control is enabled maybe try it without?

Let me know if you find anything interesting in those logs.

Thanks,
Vaughn
0
 
Rahul AgarwalTeam LeaderCommented:
Had the similar trouble, though, this is how I corrected it, Open Regedit and navigate to:
HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Feature Control\FEATURE_ENABLE_SCRIPT
Check and give full permissions to you on this key.

Silverlight should install now.
0
 
jwagmanAuthor Commented:
I have IE9, which may have different keys than yours. I have attached the reg file (as a .txt file) where the answer may be? FeatureControl.txt
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
vbighamCommented:
Is your antivirus disabled during installation?  That might help, just a thought.
0
 
jwagmanAuthor Commented:
Turned anti-virus off, rebooted, still getting same error!
0
 
vbighamCommented:
Sorry, that key should actually read:

HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\MAIN\Feature Control\FEATURE_ENABLE_SCRIPT_PASTE_URLACTION_IF_PROMPT  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.