We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

re-install ntoskrnl.exe

Anna Elaise
Anna Elaise asked
on
Medium Priority
633 Views
Last Modified: 2012-06-27
Windows Could not start because the following file is missing or corrupt :
<windows root>\system 32\ntoskrnl.exe
Please re-install a copy of the above file
Comment
Watch Question

If this is at the beginning of the startup before even getting into Windows, then you need to load the Windows disc and get into Repair mode from the initial menu.

After you are in the command interface, then do a chkdsk /r and see if that helps after a reboot.

What version of Windows is this?
Anna ElaiseCITS Manager

Author

Commented:
Thanks, I will try. It is Windows server 2003
Ok, then if it is a physical server, try the above and see what happens.
Anna ElaiseCITS Manager

Author

Commented:
Hi jbizzle979. I tried the above and I got " Set up did not find any hard disk installed in your system" Make sure any hard disks drives are powered on and properly connected to your computer and that any disk related hardware configuration is correct . This may involve running a manufacturer supplied diagnostics.
Backgroung infos. All started when I tried to use "Magic Partition" to extend my C-drive. It was dynamic and documentation says that Magic Partition would convert it back to Basic , then allow for the extension. It successfully converted a data partition and started the C partition. It was rebooting as it did for the data partition when the error message started to appear.
Ok, are your hard drives running in SATA emulation mode? If so, please change it to IDE in the BIOS and try the Repair console once more.

I have run into this error message before, but it usually is due to the SATA emulation not being recognized by Windows XP or Server 2003 discs.
Anna ElaiseCITS Manager

Author

Commented:
Thanks jbizzle979.
I got some support from minitool (the partition magic dealers) and solved the problem. I had to boot with a CD created with Bot Media Builder , then repair the boot.ini.
After that , I am able to boot normally and get the server back running.
Thanks a lot for your assistance
No problem. Glad to hear it was solved. :)
Anna ElaiseCITS Manager

Author

Commented:
Thanks a lot.
CITS Manager
Commented:
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Anna ElaiseCITS Manager

Author

Commented:
Question solved with assistance of software vendor. Please close it.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.