Backup Exec 2010 - Severe Application Error after installing

Hi all

I thought I would know how to install B/E ! Done it dozens of times, but this time around it has me stumped. And seems to have Google stumped as well!

We have a new installation of SBS2008 Premium (64 bit). The SQL Server is resident on a different server (2008 64 bit). But there is also SQL running on the primary SBS2008 (for SBSMONITORING, Kaspersky AV, and a 3rd instance called SQLEXPRESS for (Provides storage, processing and controlled access of data, and rapid transaction processing.)

Anyway, the Backup Exec Pre-installation Environment check is OK. The software seems to go on OK.

After restarting the server, I try to launch Backup Exec and it gives me a Backup Exec Application Error...

The text of the error message...



A severe application error has occurred.

Exception: System.MissingMethodException
Method not found: 'System.Object System.Windows.Threading.Dispatcher.Invoke(System.Delegate, System.Object[])'.

Stack Trace:     at BackupExec.UI.Shared.BECollectionSource`2.a(IList A_0)
   at BackupExec.UI.Shared.BECollectionSource`2.a(Object A_0, EventArgs A_1)
   at BackupExec.UI.Shared.BEThreadPool.a()
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()

There is aclose button, which after you click it, the error disappears, but the software does not run. It sits there indefintely saying "Connecting to media server".

All services set to Auto, do in fact start.

I tried deinstalling and then just installing SQL Express with a special instance I called BACKUPEX2010, and then pointing the Backup Exec installtion to this instance, but no better off.

Any thoughts?

Thanks in advance
Michael Backup Exec 2010 error when launching
mikhaelSenior Sales EngineerAsked:
Who is Participating?
 
Tony GiangrecoConnect With a Mentor Commented:
It sounds like there is a conflict either with the SQL or anti virus. I'd sugegst downloading Symantec's clean wipe which totally removes all traces of Syantec software, restart the server, let it run for an hour or two to make sure it's happy, then temporarily disable the anti virus and then reinstall BE.

Allowing BE to create and use it's own express SQL db is a good option so it doesn't interfere with any other SQL activity you have on the server.

Make sure your AV excludes the drive (it using BE B2D config).
0
 
mikhaelSenior Sales EngineerAuthor Commented:
Thanks TG-TIS, but the answer actually came from Symantec. I spent 4 hours (yes, FOUR HOURS) on the phone and remote with them.
But your answer was on the right track and you were the only one who replied. Knew it would stump 'em!
Anyway, the Symc tech had me fully deinstall .NET Framework and even download a .NET removal tool. And then reinstall that. Also,the SQL was mucked up. The special instance of SQL I had setup, they had me redo this and also about 10-15 reg edits(!) to rename the old instance. Traces were left behind of the other instance.
In the end, the Backup Exec worked BUT my Kaspersky Admin Kit broke. I need to reinstall that! (It is also SQL driven).
Thanks for your help
Michael
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.