We help IT Professionals succeed at work.

Sandboxed Visual webpart in SharePoint 2010 not deploying

1,163 Views
Last Modified: 2012-05-11
Hi,

I am trying to create a sandboxed Visual w.p. in sharepoint 2010.I unable to deploy it.
I followed these steps...
 Created Empty sharepoint Project-->Add New item->Visual w.p.-->write some code->Build (build...ok,successful)->deploy->"Error"->Please help me...

Error 1 The deployment type "TemplateFile" of file "emptySandboxedSoln1UserControl.ascx" in Project Item "emptySandboxedSoln1" is not compatible with a Feature in a Sandboxed Solution. c:\users\administrator\documents\visual studio 2010\Projects\emptySandboxedSoln1\emptySandboxedSoln1\Features\Feature1\Feature1.feature emptySandboxedSoln1

my sharepoint 2010 sandboxed Scervice is already started .
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
2nd Case--> with normal sandboxed w.p.:

if i used normal sandboxed w.p. instead of visual sandboxed w.p.->then it is building and getting deployed also.

But on page it showing this error:

Web Part Error: Unhandled exception was thrown by the sandboxed code wrapper's Execute method in the partial trust app domain: An unexpected error has occurred.

Need some help..Thanks in advance

Comment
Watch Question

Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
ok
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.