We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Accessing pub app and getting error message "An error occurred while making the requested connection. "

Medium Priority
599 Views
Last Modified: 2012-05-11
Hello,

I'm evaling XenApp6 and cannot seem to get past the following error message "An error occurred while making the requested connection." whenever I launch any pub app.

Here is my setup

1 - Win2008 R2 x64-bit (XenApp6, Web Interface v5.4.0.59)
1 - Win2008 R2 x64-bit (XenApp6 used for published apps)
1 - Win2008 R2 x64-bit (XenApp6 license server with eval licenses)

I have everything installed per the XenApp6 requirements but must be missing or overlooking something that prevents me from accesing these pub apps.

Help.
 
 

Comment
Watch Question

Commented:
Few questions. Are you accessing through web interface? Are you sitting inside or outside the network? Has this ever worked? What XML port are you using? (default is 80). Does web interface exist on the xenapp server?

I've seen this error usually from web interface when the XML config on web interface is not configured correctly. I've also seen this error when web interface is on the same box as xenapp and the XML port is configured to share port 80 with iis. Sometimes the listener is grabbed by IIS and doesn't allow XML to work properly.

In that case I would change XML to port 88. Reconfigure web interface to use port 88 as well. There is a powershell command to change the port to 88.

Author

Commented:
AdamBNYC,

I appreciate your help.   We are using Web Interface and it is installed on a XenApp6 Server and when we installed XenApp 6 we told it to use port 85 for everything related to Citrix.   It has not worked since day 1 of the install.

Where can I check to make sure XML is using port 85?  I thought it was inside Web Interface but if there are other palces I need to check on the server let me know.

Commented:
Do a netstat -an on the xenapp server and see if its listening on port 85.

Commented:
it should look like this

TCP    0.0.0.0:85           0.0.0.0:0              LISTENING

Author

Commented:
I ran the "netstat -a" command as you said from all Citrix XenApp servers and they all had the following


 Proto  Local Address          Foreign Address        State
 TCP    0.0.0.0:85             ServerXXX:0          LISTENING

All seems to well on the port side.   Can you think of something else I can try?

Commented:
ok, So it seems that the XenApp server is listening on the right port. Can you please verify your web interface settings? If you can take a snapshot of the XML setting and of the STA settings.

Also, are you accessing the environment over the WAN or over the LAN currently?

Commented:
Also, check the eventvwr on the server that is running the web interface. What is the error in there?
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview

Commented:
Glad you figured it out. Request a refund of your points.
LeeTutorretired
CERTIFIED EXPERT
Top Expert 2009

Commented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.