2003 SBS Time Clock inaccurate on domain.

Sometime in the last year or so, our SBS server's clock has been falling slowly behind, but now it has jumped ahead by about 11 minutes 27 sec

We used to manually update the time, but now when I update the clock, it stays for a bit and then jumps back ahead.  All our user logon scripts set the time to the SBS and it's causing confusion as to what time it actually is for emails,electronic documents, etc.

The Windows Time service is running, I did a restart on the service and got a windows event saying: "The time provider NtpClient is currently receiving valid time data from time.nist.gov (ntp.m|0x0|172.16.1.6:123->192.43.244.18:123)."

If I run a net time /querysntp on the SBS I get: time.nist.gov,time.windows.com

Current time on our servers is 12:11:27. Current time on Time.gov is 12:00:00

What could be causing our time to be off, and how can I get it back on track?




LVL 1
LogisticsOneAsked:
Who is Participating?
 
LogisticsOneAuthor Commented:
I ran your top code on the standalone server:

w32tm /config /syncfromflags:manual "/manualpeerlist:0.us.pool.ntp.org,0x1 1.us.pool.ntp.org,0x1 2.us.pool.ntp.org,0x1 3.us.pool.ntp.org,0x1" /reliable:yes

w32tm /config /update

net stop w32time && net start w32time

w32tm /resync /rediscover

Then I set the SBS server to sync from the standalone:

w32tm /config /syncfromflags:manual "/manualpeerlist:[standalone ip address],0x1" /reliable:yes

w32tm /config /update

net stop w32time && net start w32time

w32tm /resync /rediscover

Now if I run a w32tm /monitor /domain:[domain name] It shows both DC's (SBS has **PDC**) and the NTP offset has gone from -739.9s to -.7s and the SBS is getting it's time from the IP address of the standalone.  I've run the monitor a bunch of times over the last 10 min and it looks like it's averaging about a -.7s offset.  It looks like our SBS just can't keep time anymore.

If I run a w32tm /resync /rediscover on a client, the time gets updated to the correct time.  So I'll either push out a batch update file or just wait the 8 hours until all the clients resync (or people log off and back on again).
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
At an elevated command prompt:

w32tm /query /source

It may reply CMOS Clock or time.windows.com

Run the following:

w32tm /config /syncfromflags:manual "/manualpeerlist:0.ca.pool.ntp.org,0x1 1.ca.pool.ntp.org,0x1 2.ca.pool.ntp.org,0x1 3.ca.pool.ntp.org,0x1" /reliable:yes

w32tm /config /update

net stop w32time && net start w32time

w32tm /resync /rediscover

Replace the Canadian Pool.NTP.org servers with your own.

Then:

w32tm /query /source

The response should be one of the pool.ntp.org servers.

Philip
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Next time you've scheduled server downtime, check the Time in the BIOS.

When was he last time you change the CMOS battery if applicable?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
Brian PiercePhotographerCommented:
You can set the SBS server to sync time automatically from a time server http://support.microsoft.com/kb/816042

BTW - you don't need to use a logon script to sync time on client machines - it will sync automatically - see http://www.windowsnetworking.com/articles_tutorials/configuring-windows-time-service.html
0
 
LogisticsOneAuthor Commented:
I forgot to mention this but I'm not sure if it matters or not.  Our SBS 2003 has been virtualized and is running on a new server that's less than a year old so the battery is probably still good.  Using Hyper-V on a Windows Server 2008R2.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
ah! well host server shouldn't be an issue.
0
 
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
do you have other VMs with similar time issues?
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
See:

http://blog.mpecsinc.ca/2011/01/hyper-v-preparing-high-load-vm-for-time.html

Set your host to sync with pool.ntp.org. Set the host's firewall to allow NTP requests inbound from the local subnet it is one.

Tweak the earlier command on SBS to the following:

w32tm /config /syncfromflags:manual "/manualpeerlist:Hyper-V_Host,0x1" /reliable:yes

That will solve your problem.

Philip
0
 
LogisticsOneAuthor Commented:
After reading some more on the time issue and the way Windows domains handle it I had a question.  (probably should have been in the initial post but didn't realize exactly how it all worked yet)

We have 2 DC's on our domain, the virtualized SBS2003 and a Standard Windows server 2003 box.  Currently the virtual host is getting it's time from our Standard 2003 server and one of our other 2008 boxes is getting it's time from the SBS.  

Would it be a better idea to set the virtual SBS to /reliable:no and then run your top set of commands on the 2003 box and make that our central time source?

Thanks
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Follow the instructions above to set your standalone as the /reliable:yes and have SBS pull its time from it.

Make sure the Windows Firewall allows NTP from SBS and the other VMs.

Philip
0
 
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Check the blog post for the registry settings changes to the W32Time setup that increases the polling frequency so that the variance is not so high.

Philip
0
 
LogisticsOneAuthor Commented:
Just putting mine there since it has both of MPECSInc's comments in one post.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.