Sharepoint Secured Content

Hello,

I have a weird issue where one of the sites in my site list is showing up to a user who does not have access to it, but the other sites they do not have access to do not show up.
LVL 6
markterryAsked:
Who is Participating?
 
kukdaiCommented:
Check if that site has anonymous access enabled
0
 
markterryAuthor Commented:
It seems that when I add a link to the quicklaunch or toplink bar after the initial site creation this happens. Those sites which were added as part of the create site wizard, which the option to be on the quicklaunch, do not show up when logged in as user without access.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
kukdaiCommented:
if those sites were not anonymous enabled then it wont show unless u are logged in.
0
 
markterryAuthor Commented:
I don't think you get what I am saying.

I am saying that I have a site which is for a group of users, and there are sub sites for sub groups of users. on the main group site, there are quicklaunch links for the sub sites, and any site added to that quicklaunch outside of the create site wizard show up for everyone, regardless if they have access or not. and the other sites that were added as part of the create site wizard do not show up in quicklaunch for users that do not have access to the site.

There is no anonymous access.
0
 
kukdaiCommented:
thats what i am saying creating sites outside of the site wizard means what i didn't get it. see if you are adding an absoulute link to a quick lunch then it should be visible but if these is  an relative site link to a site then it will be visible to only those person who have access to that site
0
 
markterryAuthor Commented:
It is a relative site link: /clients/ClientSite is the quicklaunch link I added.
0
 
kukdaiCommented:
so in this case say User A doesn't have access to ClientSite then he can't see the relative link created. So whereever he browse he can never see the link to that Site.
 
Try give him some read only permission and remove again then you can realize the difference.
This is out of the box properties of Sharepoint
0
 
markterryAuthor Commented:
User A has access to Client Site A, but not Client Site B. However, both links show up in the parent quicklaunch to both sites. User A cannot see Client Site C, because it was addded to the quicklaunch during the creation wizard process. If User A clicks the Quicklaunch link to Client site B, he gets a message from sharepoint stating he has no access. but yet, it still shows up in QuickLaunch. Client Site B was added to QuickLaunch after being created, not during the creation process. Using a relative path. I have deleted the quicklaunch link and recreated with relative path of /Clients/ClientSiteB just to be sure.
0
 
kukdaiCommented:
so one links is created manually and other is automatically by sharepoint
0
 
markterryAuthor Commented:
Found my answer in another thread. Thank you.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.