We help IT Professionals succeed at work.

Sharepoint  Secured Content

markterry
markterry asked
on
Medium Priority
296 Views
Last Modified: 2012-05-11
Hello,

I have a weird issue where one of the sites in my site list is showing up to a user who does not have access to it, but the other sites they do not have access to do not show up.
Comment
Watch Question

Uttam (Kukdai) DhakalSharePoint SME
CERTIFIED EXPERT

Commented:
Check if that site has anonymous access enabled

Author

Commented:
It seems that when I add a link to the quicklaunch or toplink bar after the initial site creation this happens. Those sites which were added as part of the create site wizard, which the option to be on the quicklaunch, do not show up when logged in as user without access.
Uttam (Kukdai) DhakalSharePoint SME
CERTIFIED EXPERT

Commented:
if those sites were not anonymous enabled then it wont show unless u are logged in.

Author

Commented:
I don't think you get what I am saying.

I am saying that I have a site which is for a group of users, and there are sub sites for sub groups of users. on the main group site, there are quicklaunch links for the sub sites, and any site added to that quicklaunch outside of the create site wizard show up for everyone, regardless if they have access or not. and the other sites that were added as part of the create site wizard do not show up in quicklaunch for users that do not have access to the site.

There is no anonymous access.
Uttam (Kukdai) DhakalSharePoint SME
CERTIFIED EXPERT

Commented:
thats what i am saying creating sites outside of the site wizard means what i didn't get it. see if you are adding an absoulute link to a quick lunch then it should be visible but if these is  an relative site link to a site then it will be visible to only those person who have access to that site

Author

Commented:
It is a relative site link: /clients/ClientSite is the quicklaunch link I added.
Uttam (Kukdai) DhakalSharePoint SME
CERTIFIED EXPERT

Commented:
so in this case say User A doesn't have access to ClientSite then he can't see the relative link created. So whereever he browse he can never see the link to that Site.
 
Try give him some read only permission and remove again then you can realize the difference.
This is out of the box properties of Sharepoint

Author

Commented:
User A has access to Client Site A, but not Client Site B. However, both links show up in the parent quicklaunch to both sites. User A cannot see Client Site C, because it was addded to the quicklaunch during the creation wizard process. If User A clicks the Quicklaunch link to Client site B, he gets a message from sharepoint stating he has no access. but yet, it still shows up in QuickLaunch. Client Site B was added to QuickLaunch after being created, not during the creation process. Using a relative path. I have deleted the quicklaunch link and recreated with relative path of /Clients/ClientSiteB just to be sure.
Uttam (Kukdai) DhakalSharePoint SME
CERTIFIED EXPERT

Commented:
so one links is created manually and other is automatically by sharepoint
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Found my answer in another thread. Thank you.
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.