SBS2011 RWD Remote Desktop Access Issue

We have a SBS2011 Standard setup and I have one user at home that has Windows XP with SP3 applied.

They can connect to the Remote Web Desktop, but when they try and connect to their internal desktop at the office, the Remote Access ActiveX Control (redist) will not appear in add-ons to enable it.

No other remote user is having issues with this on other WinXP machines.

I've heard that WinXP with SP3 is a problem when getting the Remote Access ActiveX Control working, but can't seem to find a solution.

Is there a place where I can get an installer for the redist just to install this control into IE 8?

Any other ideas how to get this control to load and become visible in the IE 8 add-ons?

Thanks,

John

LVL 1
WebGeeksUnlimitedAsked:
Who is Participating?
 
Rob WilliamsConnect With a Mentor Commented:
You may want to review the following Active-x fixes. The article references SBS 2008, but the same applies to SBS 2011
http://www.sbslinks.com/fixmyrww.htm
0
 
CincyItSolutionsCommented:
Have you tried connecting to it with a different pc? I experienced an issue with a user trying to connect to SBS2008 where IE on the client was blocking the script. Maybe try resetting IE back to defaults.
0
 
WebGeeksUnlimitedAuthor Commented:
RobWill ... the link did not provide the final solution, but as a result of that information I found that a change in the Windows registry was required to fix the issue and the user was able to load the ActiveX successfully and connect to their remote desktop.

The registry fix to apply was as follows;

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{7584c670-2274-4efb-b00b-d6aaba6d3850}]
"Compatibility Flags"=dword:00000400
"AlternateCLSID"="{6A6F4B83-45C5-4ca9-BDD9-0D81C12295E4}"

This maybe specific to WinXP with SP3 and connecting to a SBS2011, as I came across a similar one, but different key value for SBS2008.

0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
WebGeeksUnlimitedAuthor Commented:
See my comments that follow the solution, this was the ultimate fix for the issue.
0
 
Rob WilliamsCommented:
Thnaks for posting your findings WebGeeksUnlimited.
Cheers!
--Rob
0
 
WebGeeksUnlimitedAuthor Commented:
The certificate went out to lunch again after a reboot today and no one could connect remotely. I couldn't find any problem, but clearly the gateway certificate setting went into never never land for some reason.

I found this not to get the RD Gateway Manager installed to properly fix this issue as the wizards are just not doing their job right.

http://support.microsoft.com/kb/2472211/en-us?sd=rss&spid=1167

It just seems that SBS2011 has some quirky behavior and the gateway certificate disconnection is just one of them.
0
 
WebGeeksUnlimitedAuthor Commented:
I forgot to add, that once your follow the KB, open the MMC and add in the RD Gateway add-in and then you can save it to the desktop for future use.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.