• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 932
  • Last Modified:

Users unable to change search provider in IE, why?

Not sure what triggered it or how long it's been an issue, but it appears users (even domain admins) have become unable to make certain changes to IE using Internet Options.

We discovered the problem when a user asked to change their search provider from Bing to Google. We receive an error stating we don't have permission to make that change.

As far as I know, we have no GPO in place specifically blocking search providers. We only have certain things such as the Title of IE.

Where would I begin to figure out what's going on here?

Thanks in advance.
0
HospiceChesapeake
Asked:
HospiceChesapeake
  • 7
  • 3
  • 2
1 Solution
 
HospiceChesapeakeAuthor Commented:
Here's a screenshot - it may help to see what I'm talking about.
IE-Search-Provider-Error.png
0
 
yarwellCommented:
I've seen that type of error message when malware has infected a machine, may be worth a scan with Malwarebytes etc to be sure it's clean. Hijacking searches is one technique used by malware and they may seek to protect the hijack by preventing changes.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
HospiceChesapeakeAuthor Commented:
I've run Antivirus and Malware bytes, nothing found.

@jcimarron - we are running IE8 (in some cases IE9 only).
0
 
HospiceChesapeakeAuthor Commented:
@jcimarron - I checked out the links, none were really of help. Thanks though. It appears theres some lingering Group Policy that could be causing the problem, but I'm unsure. I can't find anywhere in the GPO's that effect the users. All the standard IE GPO's are not defined so they shouldn't be messing things up.
0
 
jcimarronCommented:
HospiceChesapeake--For the IE9 PC's are you using the procedure here
http://windows.microsoft.com/en-US/internet-explorer/products/ie-9/tips/search-providers  ?

And look here http://www.intowindows.com/how-to-set-google-as-default-search-engine-in-internet-explorer-9/

Another idea--Run IE without add-ons.  Start|All Programs|Accessories|System Tools|Internet Explorer (no add-ons).
0
 
HospiceChesapeakeAuthor Commented:
Here's the part you're missing... Users, including Domain Admins, cannot make any of these changes... see at the beginning of the post where I posted the image of the error. That's what's occurring. It's like a GPO or something else is overriding things.
0
 
jcimarronCommented:
HospiceChesapeake--No, I did not miss it.  I was hoping to find a way around it since you say you have investigated GPO's.  
However, a Reset of IE8 or IE9 might delete any GPO causing the problem.
http://support.microsoft.com/kb/923737
See the section "Information about the Reset Internet Explorer Settings feature for network administrators"
0
 
HospiceChesapeakeAuthor Commented:
The reset settings option is grayed out. So, there goes that idea.
0
 
yarwellCommented:
Try this :-

In the step which you have performed, you will need to set the option ”Restrict changing the default search provider” tonot configured.
 
a)  Type  gpedit.msc in the Start menu’s search box and then press Enter.
b)  Navigate to User Configuration, Administrative Templates, Windows Components, and then select  Internet Explorer in the left column of the Group Policy editor.
c)   Double-click  Restrict changing the default search provider in the Settings section of the Group Policy editor.
d)  Make sure that it is set to Not configured
e)  Click OK and restart the computer, check if this works.

Another more radical suggestion :-

Back up the following registry keys, then delete them and restart....

HKLM\SOFTWARE\Policies\Microsoft\Internet Explorer
HKCU\SOFTWARE\Policies\Microsoft\Internet Explorer
0
 
HospiceChesapeakeAuthor Commented:
Well, I can certainly tell you it's not in the GPO anywhere. So, what I'll try is your registry suggestion and see where that takes me.

I can tell you that once upon a time there was a GPO for IE, my thinking is that it was never cleared properly when it was removed and it's still lingering on these machines...

Will update you with the status. Thanks for the suggestion.
0
 
HospiceChesapeakeAuthor Commented:
This did the trick.

I assume this only needs to be run once, so I'll setup a script that will run on all machines one time only.

Thanks so much yarwell (and everyone else for their support).
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

  • 7
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now