Vista Audio Service

I cannot get Vista's Audio Service to run... I have been looking for hours for the fix. Whenever I try to start it is says that there is not enough storage is available to start error 0X8007000e.
Everything that I have found online this far has not helped.

What am I missing?
wonker2Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nobusCommented:
maybe a corrupt OS - try to repair it : http://www.bleepingcomputer.com/tutorials/tutorial148.html      

if recent, a system restore can cure it too
Jackie ManIT ManagerCommented:
have you disabled UAC?
wonker2Author Commented:
UAC is off...
I'd like to try to avoid a system restore. I just got done installing SP2 and fixing many other issues that were effecting the machine. I was so mad... thought I was set, only to realize I had no sound.
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

Jackie ManIT ManagerCommented:
First of all, I think that it is better to enable UAC.

A similar question like yours is in the link below.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_Vista/Q_23514439.html

The fix of the above problem is to run a MS utility called SubInACL.exe.

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en
wonker2Author Commented:
According to MS, subacl is not for Vista?
Jackie ManIT ManagerCommented:
It should work.

http://www.vistax64.com/powershell/127637-subinacl-vista-2008-a.html

Your registry has ran into a permission problem.
Jackie ManIT ManagerCommented:
Do create a system restore point or a system image before you try any fix.
wonker2Author Commented:
So, to avoid a mistake, do I just run the program, or is there some command line syntax that I need to do?
Jackie ManIT ManagerCommented:
According to orangutang, it says:-

"Try these modified instructions from http://www.windowsbbs.com/316029-post2.html:

Here is my modified 'fix' that has been tested:

First, download, unzip and move to \Windows\System32 the files:

SUBINACL.EXE :
http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b

Second, open notepad, and copy/paste the following:

subinacl /subkeyreg HKEY_LOCAL_MACHINE /setowner=administrators
subinacl /subkeyreg HKEY_CURRENT_USER /setowner=administrators
subinacl /subkeyreg HKEY_CLASSES_ROOT /setowner=administrators
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f
subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f
subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f
subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f

Do a File, Save as, C:\fix_reg.cmd. Run C:\fix_reg.cmd"

Source: http://www.experts-exchange.com/Hardware/Components/Sound_Cards/Q_23572038.html
Jackie ManIT ManagerCommented:
You need to make a system restore point or system image before trying any fix as I have not tried the above and have no idea of the results.

I need some time to read other stuff in relation to your problem.
Jackie ManIT ManagerCommented:
I google for the keywords of subinacl vista audio 8007000e and my findings are:-

1. for some cases, it can fix the problem but there is no exact record of the subinacl syntax being used
2. for many cases, there is no change
3. for some cases, the problem is temporarily fixed but there are new problems afterwards

In my findings, some experts suggested that the problem is caused by third party security (i.e. anti-virus / internet security / firewall) softwares and the security software has locked the change to the registry and system reserved area of the OS so that you got 0X8007000e when your audio driver try to write to the system reserved area or registry.

Can you list out the security software installed / have been installed and removed?

You might need to un-install security software using the respective removal tools and try again.
wonker2Author Commented:
THe only program on the machine is SAV Corp. edition 10.2... I doubt that would cause all this... the program is so old.... ???
Jackie ManIT ManagerCommented:
SAV may have changed some system settings, but we need evidence.

Try the following:-

1. Open an elevated command prompt (cmd)

2. run the command below.

    net localgroup Administrators /add localservice

Source: http://www.techsupportforum.com/forums/f217/solved-services-not-enough-storage-available-to-complete-this-operation-471599-2.html

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jackie ManIT ManagerCommented:
Restart computer after you run the command above and check whether the audio comes to life again.
nobusCommented:
what about running a repair install, as suggested?
wonker2Author Commented:
Already ran the net localgroup command... that fixed my windows installer issue.

Repair install, and restoring to previous states are my last resorts. I just updated and fixed other issues before I noticed the sound was not functioning. Going back in time would lose many hours of work.
Jackie ManIT ManagerCommented:
Try to un-install the audio driver, restart computer and install back the auido drive. Any errors?
Jackie ManIT ManagerCommented:
Jackie ManIT ManagerCommented:
You need to enable UAC and restart computer before you try the above fix.
wonker2Author Commented:
I read net localgroup command too quickly..
It was close to what fixed my installer issue... it did the trick perfectly!
Many thanks.
Jackie ManIT ManagerCommented:
Glad to know that you have solved the problem. Cheers!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.