?
Solved

vmware esxi 4.1 doesn't detect vmware tools

Posted on 2011-04-30
6
Medium Priority
?
1,013 Views
Last Modified: 2012-06-22
hi,
i just received a used IBM x3455 server with 2 dual core opteron (2.6ghz) and 8gb of ram.
i installed vmware esxi 4.1, and on it 4 VM.
The vm are running windows server 2008 standard x64.
trought vsphere 4 client i installed  vmware tools by right clicking on the wms.

the problem is that in summary tab vmware tools are not detected, it says "not installed" but in the wm they are installed and the icon is present under controll pannell.


Any idea?
0
Comment
Question by:oloap88
6 Comments
 
LVL 124

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 1000 total points
ID: 35498010
is the vmware tools service started?

is the firewall enabled?

try reinstalling vmware tools, or uninstall and reinstall
0
 
LVL 42

Assisted Solution

by:Paul Solovyovsky
Paul Solovyovsky earned 500 total points
ID: 35498011
1.  You actuall have to make sure that the vmware tools are installed, you'll see the installation going on in the VM
2.  Make sure you have the CD Drive added to the VM
3.  If they don't install via console go into the OS, browse to the CD, click setup and install
4.  Reboot and you're set
0
 
LVL 3

Author Comment

by:oloap88
ID: 35498214
hi thanks for help,
the tools are actually installed since i started the install from vsphere client, then it loaded an immage into the virtual cdrom and then i ran the installation from inside the virtual machine.
it required a reboot and after the network adapter were recognized, and an icon called vmware tools was added to control pannel.

under windows services i can see just vmware update helper, that is started and starts automatically.

windows firewall is on, can this cause the problem?
is possible to just create an exception instead of tourning it off?


what is strange is that when i install them from vsphere client it show a message saying:

wmware tools greatly enhance graphic and mouse performance in your virtual machine.

Warning: you cannot install vmware tools package untill guest operating system is running. if your guest operating system is not running,"

than it stops, that doesn't make much sense grammatically..

what means? i tried shutting down the machine but then is not possible anymore to install vmware tools (the options turn gray)

0
Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

 
LVL 124

Assisted Solution

by:Andrew Hancock (VMware vExpert / EE MVE^2)
Andrew Hancock (VMware vExpert / EE MVE^2) earned 1000 total points
ID: 35498264
you can only install the tools when the vm is running.

try reinstallation of tools.

or uninstall tools and reinstall.

just quicly stop firewall as a test.
0
 
LVL 16

Assisted Solution

by:Danny McDaniel
Danny McDaniel earned 500 total points
ID: 35499131
the vmware upgrade helper service isn't the one that matters (that service just helps with keeping network card settings should you ever upgrade the virtual hardware on the VM).

There should be a vmware tools service that is there and running.
0
 
LVL 3

Author Closing Comment

by:oloap88
ID: 35504039
hi,
thanks everybody, i just reinstalled and it works. the point was to select a "typical" install instead of "full" like i did before.
don't know why but i tried (once working) to unistall and re-perform a full type install and it didn't work again... reinstaalled with tipical settuings and back working again.... weird!
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For anyone that has accidentally used newSID with Server 2008 R2 (like I did) and hasn't been able to get the server running again because you were unlucky (as I was) and had no backups - I was able to get things working by doing a Registry Hive rec…
August and September have been big months for VMware—from VMworld last month to our new Course of the Month in VMware Professional - Data Center Virtualization. We reached out to Andrew Hancock, resident VMware vExpert, to have a more in-depth discu…
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question