[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1601
  • Last Modified:

yum update fails

Cannot do a "yum update" I keep getting a dependency error HELP!


--> Running transaction check
---> Package libv4l.i386 0:0.5.9-3.el5 set to be updated
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: opal
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: ekiga
--> Processing Dependency: pwlib >= 1.10.1 for package: opal
--> Processing Dependency: pwlib >= 1.10.1 for package: ekiga
--> Finished Dependency Resolution
opal-2.2.2-1.1.0.1.i386 from installed has depsolving problems
  --> Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
ekiga-2.0.2-7.0.2.i386 from installed has depsolving problems
  --> Missing Dependency: pwlib >= 1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
ekiga-2.0.2-7.0.2.i386 from installed has depsolving problems
  --> Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
opal-2.2.2-1.1.0.1.i386 from installed has depsolving problems
  --> Missing Dependency: pwlib >= 1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
Error: Missing Dependency: pwlib >= 1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
Error: Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
Error: Missing Dependency: pwlib >= 1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
Error: Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@compaq ~]# rpm -qa | grep pwlib
pwlib-1.10.1-7.0.1.el5

[root@compaq etc]# cat redhat-release
CentOS release 5.6 (Final)
[root@compaq etc]#
0
bs98909
Asked:
bs98909
  • 4
  • 2
2 Solutions
 
Abhishek_ChibCommented:
Clean the REPO data

# yum clean all

then try to install
0
 
bs98909Author Commented:
Nope still the same:


[root@compaq]# yum clean all
Loaded plugins: fastestmirror
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@compaq Single_File_PHP]# yum update
Loaded plugins: fastestmirror
Determining fastest mirrors
 * base: ftp.osuosl.org
 * epel: mirror.hiwaay.net
 * extras: mirrors.netdna.com
 * updates: mirror.batblue.com
atrpms                                                                                           | 3.0 kB     00:00    
atrpms/primary_db                                                                                | 1.1 MB     00:01    
base                                                                                             | 1.1 kB     00:00    
base/primary                                                                                     | 954 kB     00:00    
base                                                                                                          2683/2683
epel                                                                                             | 3.7 kB     00:00    
epel/primary_db                                                                                  | 3.0 MB     00:01    
http://mirrors.netdna.com/centos/5.6/extras/i386/repodata/repomd.xml: [Errno 14] HTTP Error 403: Forbidden
Trying other mirror.
extras                                                                                           | 2.1 kB     00:00    
extras/primary_db                                                                                | 181 kB     00:00    
updates                                                                                          | 1.9 kB     00:00    
updates/primary_db                                                                               | 350 kB     00:00    
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package firefox.i386 0:3.6.17-1.el5.centos set to be updated
---> Package gdbm.i386 0:1.8.0-26.2.1.el5_6.1 set to be updated
---> Package glibc.i686 0:2.5-58.el5_6.3 set to be updated
---> Package glibc-common.i386 0:2.5-58.el5_6.3 set to be updated
---> Package glibc-devel.i386 0:2.5-58.el5_6.3 set to be updated
---> Package glibc-headers.i386 0:2.5-58.el5_6.3 set to be updated
---> Package libuser.i386 0:0.54.7-2.1.el5_5.2 set to be updated
---> Package libvirt.i386 0:0.8.2-15.el5_6.3 set to be updated
---> Package libvirt-python.i386 0:0.8.2-15.el5_6.3 set to be updated
---> Package nscd.i386 0:2.5-58.el5_6.3 set to be updated
---> Package nss.i386 0:3.12.8-4.el5_6 set to be updated
---> Package nss-tools.i386 0:3.12.8-4.el5_6 set to be updated
---> Package ptlib.i386 0:2.6.7-1.el5 set to be updated
--> Processing Dependency: libv4l2.so.0 for package: ptlib
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: opal
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: ekiga
--> Processing Dependency: pwlib >= 1.10.1 for package: opal
--> Processing Dependency: pwlib >= 1.10.1 for package: ekiga
---> Package vnc.i386 0:4.1.2-14.el5_6.6 set to be updated
---> Package vnc-server.i386 0:4.1.2-14.el5_6.6 set to be updated
---> Package xorg-x11-server-Xnest.i386 0:1.1.1-48.76.el5_6.4 set to be updated
---> Package xorg-x11-server-Xorg.i386 0:1.1.1-48.76.el5_6.4 set to be updated
---> Package xorg-x11-server-utils.i386 0:7.1-5.el5_6.2 set to be updated
---> Package xorg-x11-xfs.i386 1:1.0.2-5.el5_6.1 set to be updated
---> Package xulrunner.i386 0:1.9.2.17-3.el5 set to be updated
--> Running transaction check
---> Package libv4l.i386 0:0.5.9-3.el5 set to be updated
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: opal
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: ekiga
--> Processing Dependency: pwlib >= 1.10.1 for package: opal
--> Processing Dependency: pwlib >= 1.10.1 for package: ekiga
--> Finished Dependency Resolution
opal-2.2.2-1.1.0.1.i386 from installed has depsolving problems
  --> Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
ekiga-2.0.2-7.0.2.i386 from installed has depsolving problems
  --> Missing Dependency: pwlib >= 1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
ekiga-2.0.2-7.0.2.i386 from installed has depsolving problems
  --> Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
opal-2.2.2-1.1.0.1.i386 from installed has depsolving problems
  --> Missing Dependency: pwlib >= 1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
Error: Missing Dependency: pwlib >= 1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
Error: Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
Error: Missing Dependency: pwlib >= 1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
Error: Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@compaq]#
0
 
Abhishek_ChibCommented:
Here is the problem :

epel/primary_db                                                                                  | 3.0 MB     00:01    
http://mirrors.netdna.com/centos/5.6/extras/i386/repodata/repomd.xml: [Errno 14] HTTP Error 403:

NetDNA central repo is not working properly :

Try :

# rpm -Uvh http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-4.noarch.rpm
# yum clean all

Now try again.

0
Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

 
bs98909Author Commented:
previously i did a:

yum update --skip-broken

which installed some of the updates, but still have errors. followed your suggestion and this is the output:

[root@compaq]# rpm -Uvh http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-4.noarch.rpm
Retrieving http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-4.noarch.rpm
Preparing...                ########################################### [100%]
    package epel-release-5-4.noarch is already installed

[root@compaq]# yum clean all
Loaded plugins: fastestmirror
Cleaning up Everything
Cleaning up list of fastest mirrors

[root@compaq]# yum updateLoaded plugins: fastestmirror
Determining fastest mirrors
 * base: mirrors.liquidweb.com
 * epel: mirrors.rit.edu
 * extras: centos.supsec.org
 * updates: mirror.batblue.com
atrpms                                                                                           | 3.0 kB     00:00    
atrpms/primary_db                                                                                | 1.1 MB     00:01    
base                                                                                             | 1.1 kB     00:00    
base/primary                                                                                     | 954 kB     00:00    
base                                                                                                          2683/2683
epel                                                                                             | 3.7 kB     00:00    
epel/primary_db                                                                                  | 3.0 MB     00:09    
extras                                                                                           | 2.1 kB     00:00    
extras/primary_db                                                                                | 181 kB     00:00    
updates                                                                                          | 1.9 kB     00:00    
updates/primary_db                                                                               | 350 kB     00:00    
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ptlib.i386 0:2.6.7-1.el5 set to be updated
--> Processing Dependency: libv4l2.so.0 for package: ptlib
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: opal
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: ekiga
--> Processing Dependency: pwlib >= 1.10.1 for package: opal
--> Processing Dependency: pwlib >= 1.10.1 for package: ekiga
--> Running transaction check
---> Package libv4l.i386 0:0.5.9-3.el5 set to be updated
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: opal
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: ekiga
--> Processing Dependency: pwlib >= 1.10.1 for package: opal
--> Processing Dependency: pwlib >= 1.10.1 for package: ekiga
--> Finished Dependency Resolution
opal-2.2.2-1.1.0.1.i386 from installed has depsolving problems
  --> Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
ekiga-2.0.2-7.0.2.i386 from installed has depsolving problems
  --> Missing Dependency: pwlib >= 1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
ekiga-2.0.2-7.0.2.i386 from installed has depsolving problems
  --> Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
opal-2.2.2-1.1.0.1.i386 from installed has depsolving problems
  --> Missing Dependency: pwlib >= 1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
Error: Missing Dependency: pwlib >= 1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
Error: Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
Error: Missing Dependency: pwlib >= 1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
Error: Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@compaq]#
 
0
 
bs98909Author Commented:
Just for giggles I did a "reinstall" of the libpt_linux_x86_r.so.1.10.1 package -- but still no joy
And I did already try the suggested commands by yum with no errors or problems with the catalogs:
      package-cleanup --problems
      package-cleanup --dupes

[root@compaq Single_File_PHP]# yum reinstall libpt_linux_x86_r.so.1.10.1
Loaded plugins: fastestmirror
Setting up Reinstall Process
Loading mirror speeds from cached hostfile
 * base: mirrors.liquidweb.com
 * epel: mirrors.rit.edu
 * extras: centos.supsec.org
 * updates: mirror.batblue.com
Resolving Dependencies
--> Running transaction check
---> Package pwlib.i386 0:1.10.1-7.0.1.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================================
 Package                   Arch                     Version                              Repository                Size
=============================================================================================================
Reinstalling:
 pwlib                     i386                     1.10.1-7.0.1.el5                     base                     821 k

Transaction Summary
=============================================================================================================
Remove        0 Package(s)
Reinstall     1 Package(s)
Downgrade     0 Package(s)

Total download size: 821 k
Is this ok [y/N]: y
Downloading Packages:
pwlib-1.10.1-7.0.1.el5.i386.rpm                                                                  | 821 kB     00:00    
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : pwlib                                                                                            1/1

Installed:
  pwlib.i386 0:1.10.1-7.0.1.el5                                                                                        

Complete!

[root@compaq ~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.liquidweb.com
 * epel: mirrors.rit.edu
 * extras: centos.supsec.org
 * updates: mirror.batblue.com
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ptlib.i386 0:2.6.7-1.el5 set to be updated
--> Processing Dependency: libv4l2.so.0 for package: ptlib
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: opal
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: ekiga
--> Processing Dependency: pwlib >= 1.10.1 for package: opal
--> Processing Dependency: pwlib >= 1.10.1 for package: ekiga
--> Running transaction check
---> Package libv4l.i386 0:0.5.9-3.el5 set to be updated
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: opal
--> Processing Dependency: libpt_linux_x86_r.so.1.10.1 for package: ekiga
--> Processing Dependency: pwlib >= 1.10.1 for package: opal
--> Processing Dependency: pwlib >= 1.10.1 for package: ekiga
--> Finished Dependency Resolution
opal-2.2.2-1.1.0.1.i386 from installed has depsolving problems
  --> Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
ekiga-2.0.2-7.0.2.i386 from installed has depsolving problems
  --> Missing Dependency: pwlib >= 1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
ekiga-2.0.2-7.0.2.i386 from installed has depsolving problems
  --> Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
opal-2.2.2-1.1.0.1.i386 from installed has depsolving problems
  --> Missing Dependency: pwlib >= 1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
Error: Missing Dependency: pwlib >= 1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
Error: Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package ekiga-2.0.2-7.0.2.i386 (installed)
Error: Missing Dependency: pwlib >= 1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
Error: Missing Dependency: libpt_linux_x86_r.so.1.10.1 is needed by package opal-2.2.2-1.1.0.1.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@compaq ~]#
0
 
joolsCommented:
did you force install the opal or ekiga packages?

if the packages are not used you can try to in install them the run the update again.
0
 
bs98909Author Commented:
Gee wiz why didn't I think of that?

Opal was never invited to the party any how, did a yum remove. and now yum updates work. Thanks!

Summary : Open Phone Abstraction Library (opal)
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now