SBS 2003 Monitoring and Reporting Problems

I have an SBS 2003 SP2 server that gives me a "The page cannot be displayed" message when I go to Monitoring and Reporting in Server Management.   It runs WSIS 2.0 which also has problems.  WSUS 2.0 sort of works but seems to have too many items to update to run properly (over 20,000).   I've applied all of the Microsoft Patchs to the server.

I"ve run into this problem with SBS 2003 servers running WSUS 3.0.   Cleaning up the WSUS 3.0 database solved my problem there.   Unfortunately the WSUS 2.0 database doesn't seem to have the features available to clean it.   I've tried running wsusutil but it will time out mid cleaning.

How can I get monitoring and reporting working again?
LVL 4
kdubendorfAsked:
Who is Participating?
 
Larry Struckmeyer MVPConnect With a Mentor Commented:
Hi:
This is an oft repeated senerio... read down through this page for lots of suggestions for WSUS on SBS and the Monitoring and Reporting issue.  Basically, run the codeplex cleanup on WSUS 2, upgrade to WSUS 3.2 (long past time, WSUS 2 is not supported), and run server cleanup weekly as a scheduled task.  It that does not fix it, uninstall/reinstall Monitoring and Reporting, from Add/Remove Windows Samall Business Server, then uninstall/reinstall WSUS.

http://msmvps.com/blogs/bradley/archive/tags/WSUS/default.aspx

0
 
kdubendorfAuthor Commented:
I had seen this but didn't see much on WSUS 2.0   So codeplex is the answer for the initial clean up?
0
 
kdubendorfAuthor Commented:
Actually this link mentions little on WSUS 2.0 and doesn't reference codeplex at all.   Do you have a recommended link for that?
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
kdubendorfAuthor Commented:

I went hunting for codeplex and found a wsus_cleanup_cl.exe tool.  To me it appears to be written for WSUS 3.0.   I am getting the following error message:

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or ass
embly 'Microsoft.UpdateServices.Administration, Version=3.0.6000.273, Culture=ne
utral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system c
annot find the file specified.
File name: 'Microsoft.UpdateServices.Administration, Version=3.0.6000.273, Cultu
re=neutral, PublicKeyToken=31bf3856ad364e35'
   at WSUS_Cleanup_CL.Class1.Main(String[] args)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\M
icrosoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure lo
gging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fus
ion!EnableLog].

I am executing this from c:\.

Thanks.
0
 
Larry Struckmeyer MVPCommented:
I am not sure what to tell you about a program that is not supported any longer.  Perhaps go back to uninstall/reinstall then immediately upgrade to WSUS 3.2.  

But before you do that, maybe look here:
First read:
http://wsus.codeplex.com/discussions
then dll and install/run
http://wsus.codeplex.com/releases/view/18473

first read:
http://wsus.codeplex.com/discussions
Then dl and install/run:
http://wsus.codeplex.com/releases/view/17612
0
 
kdubendorfAuthor Commented:
While I recognize this is unsupported, it is still a question with merit and more help along the lines of getting out of the situation would have been beneficial
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.