[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1531
  • Last Modified:

Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using <IP> as the value of the DISPLAY variable

I am trying to install Oracle 9i Database server software on CentOS 5.5 on an Amazon Cloud server through SSH(putty). When the runInstaller is invoked it throws the error -
Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using '204.236.227.59:0.0' as the value of the DISPLAY variable

I tried the below steps

1. #  xhost +
xhost:  unable to open display ""
2. export DISPLAY=204.236.227.59:0.0
3. export DISPLAY=:0.0
4 uncommented the below lines from /etc/ssh/sshd_config file
X11Forwarding yes
X11DisplayOffset 10
X11UseLocalhost yes. And restarted sshd service.

But nothing helps and problem still persists. Tried to connect through 'XWinLogon' but unable to do so. Please let me know what can be done to set the display correctly and start the database installation.
0
makk2010
Asked:
makk2010
  • 4
  • 3
  • 2
  • +2
3 Solutions
 
OP_ZaharinCommented:
- do you run the installer as the root user? run it as the oracle user instead.
0
 
CEHJCommented:
Is it a gui installer? Do you have an X server running on the same box as Putty?
0
 
mrjoltcolaCommented:
To simplify just start a vncserver (VNC) and you'll have a remote X desktop. That way you can even disconnect from the session while the installer finishes.

Do you know how to start vnc? Also after your .vnc directory creates, edit the xstartup file and uncomment first two the lines according to the comments you see in the file.

Something like:

# Uncomment the following two lines for normal desktop:
 unset SESSION_MANAGER
 exec /etc/X11/xinit/xinitrc


Then login and startup Oracle installer.
0
Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

 
OP_ZaharinCommented:
- if you have My Oracle Support (MOS) contract, look for document ID 567004.1 on java.lang.InternalError: Can't connect to X11 window server using DISPLAY variable. the document explain in details step to overcome the problems.
0
 
CEHJCommented:
However much configuration you do, you're not going to be able to see a windowed installer on the box on which Putty's running without an X server also running on it
0
 
makk2010Author Commented:
I used the utility MobaXterm and was able to start the installer from it.
0
 
makk2010Author Commented:
ofcourse logging in directly as Oracle user(avoiding su ) allowed the runInstaller to start.
0
 
CEHJCommented:
Yes, and the reason would be

"MobaXterm (formerly known as MobaXVT) is an enhanced terminal WITH AN X SERVER"

(my emphasis). See my last comment
0
 
makk2010Author Commented:
Not accurate but helpful
0
 
CEHJCommented:
What is 'Not accurate'?
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

  • 4
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now