User and URL Information displaying as IP Addresses in ISA 2006 reports

Hi Experts, I have noticed that my ISA Server reports do not display the name of my users under "Top Users" section of the report but rather just the IP address of their machines. Also under the "Top Websites" it just displays the IP addresses of the top websites rather than the full URL. Kindly advise how I can get the ISA 2006 reports to display the username of my Top Users and the URL of the top websites.
nimocanICT ManagerAsked:
Who is Participating?
 
Keith AlabasterConnect With a Mentor Enterprise ArchitectCommented:
Also, make sure you are using the web proxy client (set the web proxy address in the browser proxy settings)
0
 
Keith AlabasterEnterprise ArchitectCommented:
First you need to ensure you are using an authenticated user base such as an AD group in the access rules rather than All Users. Alternatively you can deploy the ISA firewall client if you have two nics in the ISA server.
0
 
nimocanICT ManagerAuthor Commented:
Unfortunately I cannot enable authenticated users because I have alot of users that we host at our office and it would be cumbersome to keep going to them to inform them of the user account they should to authenticate. I have enabled my clients for web proxy access but when we put the settings in the browser proxy settings, we are not able to access our published servers i.e. Sharepoint and Exchange OWA. Maybe you can advise of a way around these issues?
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
Keith AlabasterEnterprise ArchitectCommented:
Then you will not pick up names in the logs.

The account name will be their active directory account - they do not need a separate user account.
For the published servers, you do not need to maually set the detatails in the proxy settings. Use a proxy pac file and wpad so that they are automatically inserted when on the network and ignored when outside.
0
 
nimocanICT ManagerAuthor Commented:
Thanks for the advise Keith, but in the case of the authentication issue, many of the guests who we connect to the internet from our offices are not AD users i.e. not part of our domain. That is the challenge. We had previously configured wpad on our ISA / DHCP server but later when we deployed our published servers, we could not connect to them even from within the network as long as the "automatically detect settings" checkbox in LAN Settings of IE was checked. It only worked when the option was unchecked. So probably this is a secondary issue to this problem that we need to resolve in order to use wpad.
0
 
nimocanICT ManagerAuthor Commented:
Also, sometimes a few user names (from our AD) show up in the ISA report with a ? next to the name. Not sure what that means.
0
 
Keith AlabasterEnterprise ArchitectCommented:
I see. As none of the organisations I work with would even dream of allowing non-company equipment or users onto the internal network it is not a situation I have had to deal with. We provide a separate wireless network for our installations for 'visitors' and the like and their vlans are brought in via the DMZ (outside of ISA/FTMG) so the published sites still operate correctly.

Names with question marks generally mean that credentials have been passed with a request but have not been validated against a directory (ISA has not been requested to validate).
0
 
nimocanICT ManagerAuthor Commented:
Ok, but still I don't understand why I cannot access our published servers from within the LAN when "automatically detect settings" is selected. If I can resolve that then I believe I can resolve the issue of the top website URLs being displayed in the ISA reports.
0
 
Keith AlabasterEnterprise ArchitectCommented:
sit at a pc. Do an nslookup of the published site - does it give an internal or external ip address?
0
 
nimocanICT ManagerAuthor Commented:
NSlookup from within my office network it gives me the internal ip address of the published site while nslookup from outside gives me the public IP address.
0
 
nimocanICT ManagerAuthor Commented:
By the way, the error I get when trying to access the published site when "automatically detect settings" is checked in the IE settings is "502 Proxy Error. The ISA Server denied the specified URL"
0
 
Keith AlabasterEnterprise ArchitectCommented:
502 is a permissions error.
Have you not exempted the internal urls?
0
 
nimocanICT ManagerAuthor Commented:
What do you mean by exempted?
0
 
nimocanICT ManagerAuthor Commented:
How do you exempt internal URLs from ISA firewall rules?
0
 
nimocanICT ManagerAuthor Commented:
I was able to resolve the problem of not being able to access the published website by creating a DMZ interface on the ISA Server and creating a network rule to enable LAN clients access the DMZ. Thanks for the comments on the authenticated users. I will implement this scenario to seperately provide internet connectivity to my non-AD users and thus be able to authenticate my AD users.
0
 
nimocanICT ManagerAuthor Commented:
The solution addressed only part of my query.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.