Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

How to share a directory so that users can connect without username/password?

Posted on 2011-05-02
12
Medium Priority
?
341 Views
Last Modified: 2012-05-11
I want to share a directory on a Win2008-server so that ALL users can access the share without having to type a username/password. Also client-computers that are not members of the AD-domain should be able to connect without username/password. How can this be done?
0
Comment
Question by:thoree
  • 4
  • 3
  • 2
  • +2
12 Comments
 
LVL 19

Expert Comment

by:Raheman M. Abdul
ID: 35503868
Right click on the share -> Properties -> Everyone -> full
0
 

Author Comment

by:thoree
ID: 35503889
I do not want everyone to have full access, I just want everyone to be able to connect and read the contents of the share without authentication.
0
 
LVL 15

Expert Comment

by:Praveen Venu
ID: 35503898
Right Click -> Share ->Permission-> Select Every one and then Read.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 6

Expert Comment

by:Osmoze
ID: 35503901
everyone means everyone including machines / users / applications ..
if you want for every user only to access the share , use groups instead of specifying one bye one ,
create a groupe in AD ( a group ex: Finnances users  or IT departement ), join all users you want that are part of the "departement" to access the share .
set this group to Read right on the share .
0
 

Author Comment

by:thoree
ID: 35503946
I still get prompted for username/password. It works if I type guest as the username with no password, but I do not want the username/password-box to pop up at all.
0
 
LVL 15

Expert Comment

by:Praveen Venu
ID: 35503954
I understand your problem.

Right Click -> Property- > Security Tab ->Select EveryOne
Then Check the Read permission below.
0
 
LVL 4

Expert Comment

by:CNS_Support
ID: 35503955
Best practice is to share with full permissions and then control use with NTFS permissions (Security Tab)
So give the Share Full Control and then on the Security Tab, give either Everyone Read Only if that is what you want.
This also gives you control to give specific users Change privilages.
0
 

Author Comment

by:thoree
ID: 35504043
My problem is not how to set up the permissions, but how to let anonymous user connect to a share without being prompted for username/password.
0
 
LVL 15

Expert Comment

by:Praveen Venu
ID: 35504071
http://technet.microsoft.com/en-us/library/cc755781(WS.10).aspx#BKMK_Local



To enable anonymous access on a local workstation or server computer
Open Local Security Settings. Click Start, click Control Panel, double-click Administrative Tools, and then double-click Local Security Policy.

In the console tree, double-click Local Policies, and then click Security Options.

In the details pane, right-click Network access: Let Everyone permissions apply to anonymous users, and then click Properties.

On the Local Security Settings tab, click Enabled, and then click OK.
0
 
LVL 19

Expert Comment

by:Raheman M. Abdul
ID: 35504095
Run->secpol.msc

Local Security Settings >Local Policies >Security Options

Disable  Accounts: Limit local account use of blank password to console only
0
 

Author Comment

by:thoree
ID: 35504226
Thanks for your answers. I have tried all these settings, but still I am prompted for username/password when connecting from a non-domain computer.
0
 
LVL 6

Accepted Solution

by:
Osmoze earned 2000 total points
ID: 35505105
the answer is here http://technet.microsoft.com/en-us/library/cc753731.aspx ( Look at NFS paragraphe)

you have to enable anounymous login to shared ressource
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
After seeing many questions for JRNL_WRAP_ERROR for replication failure, I thought it would be useful to write this article.
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

571 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question