issues with automounted drives in Fedora

I have a server that has 2 fibre channel drives that are mounted on startup. they also automount home drives for users on demand.

I changed the run level the other day (to 3 from 5) and after a reboot, the drives were not mounting. I tested restarting the server again and had the same issues. I changed the run level back to 5 and then the drives mounted after a reboot.

I ran chkconfig and the services are the same for runlevel 5, except for gpm, so I looked under /etc/rc.d/ and looked in rc3.d. I saw that there are 2 simlinks listed that are as follows:

disable_S60nfs
disable_S99autofs

Autofs is used for the mounts so I am assuming that this is the cause of the problem, but I am not sure why these links are there or if they are in fact causing the issue.

Can anyone help me understand what these links are?
LVL 12
ryan80Asked:
Who is Participating?
 
lnkevinCommented:
any idea how these links would have gotten in the folder for rc3.d?

Has to be manually set by someone or sometime the service tries to mount some things unsuccessfully for many times and disable itself. In this case, you always see it in the logs. If you don't see anything in the logs, it should be done manually.

K
0
 
lnkevinCommented:
All you have to do is remove the "disable_" from the rc levels you can keep the same rc number just to unsure other services are running prior to autofs and nfs. You may want to check rc1.d directory as well. Also, you need to ensure nfs service is enabled and running.

chkconfig nfs on
service nfs start

ckconfig autofs on
service autofs start

K
0
 
ryan80Author Commented:
any idea how these links would have gotten in the folder for rc3.d?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
lnkevinCommented:
Can anyone help me understand what these links are?

These are the run level of services. S is sevice. The numbers represent the order from low to high and the last part is the name of service. If you have disable_ in front of the service, you disable it.

K
0
 
ryan80Author Commented:
ok,

There are duplicates for these entries. for

disable_S60nfs
disable_S99autofs

there is also a

S60nfs
S99autofs

But I am guessing that these are prempted by the disable option?
0
 
pclinuxguruCommented:
What version of Fedora are you using?

I have never heard of disable_ in any of the startup script.

In your rc.3 folder the S stands for startup. The number after is the order.

You should also have a bunch of K scripts... those are kill scripts following the same with the order number.

My guess would be the disable_ are outdated (perhaps and update that didn't finish or they were modified and your update didn't delete them) scripts perhaps.

you can try doing a chkconfig --list and it will show you what starts at the various run levels.

If it shows autofs and nfs as Off in runlevel 3 then a chkconfig --level 3 autofs on would turn it "on" to boot in that runlevel.
0
 
ryan80Author Commented:
I looked at chkconfig and they are both set to on. I am just going to delete the disable_ scripts and see if that corrects the issue.
0
 
lnkevinCommented:
Sure, delete them.

K
0
 
pclinuxguruCommented:
You can also move them to another directory.

try "service nfs start" and "service autofs start" and ensure your services start.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.