ESXi System Resource Reservations

Posted on 2011-05-02
Last Modified: 2012-06-27
As my first step away from ESX toward the new and exciting world of ESXi I apparenlty missed somethign somewhere.

It was my undestanding that in ESXi there was no reason for Resource reservations.  Furethermore when I look a the default configuration I see 0MB reserved.

However, I have a 3 host cluster with with 50 VM's.  When I tried to remediate my servers with the 2 patches released on 4/28, I received the following error:

Migration to host <<unknown>> failed with error Out of memory (195887124).
vMotion migration [220855820:1304344934423656] generator failed to allocate publicData memory

Can someone please point me in the right direction here.  My initial reaction was that I needed to increase the ESX memory reservation, but I wanted to bounce the idea off of some experts....

And FYI, when I run all of my VM's on 2 hosts they both sit at 60% memory Usage.
Question by:brittonv
    LVL 16

    Expert Comment

    can you confirm that manually kicking off a vmotion works?  Make sure that you can migrate to/from each host and try a couple different VM's.

    Seldom is it necessary to change the host's memory reservation from their default settings.
    LVL 8

    Author Comment

    Yes, it works.  Additionally  I tried to remediate all 3 servers at once (Something that I don't usually do but this isn't in production yet.  The first server vmotioned all the VM's, installed the patches, exited Maintenace mode all perfectly.

    Then when the second server vmotioned the VM's it died after successfully vmotioning about 60% of the VM's.  I manually put it in MM and it did so fine.

    LVL 16

    Accepted Solution

    what version of ESXi and vCenter are you using?  Sounds like an Update Manager Server issue if the semi-manual methods work but the one fell-swoop patching of the cluster doesn't.

    If you are on the latest release (4.1 Update 1) and the above is true, you should probably open a ticket with VMware as it's not a common issue.
    LVL 2

    Assisted Solution

    Sometimes esx can get itself in a twist with update manager, it might be best to run each host through a maintenance cycle and reboot it, then try again. Or, if you have service console access, restarting the vmware management service on each host.

    This doesn't sound like anything to do with resource reservations from the information you have provided.

    Write Comment

    Please enter a first name

    Please enter a last name

    We will never share this with anyone.

    Featured Post

    Top 6 Sources for Identifying Threat Actor TTPs

    Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

    Using a software based iSCSI solution, there is no requirement to purchase an hardware iSCSI initiator or TOE (TCP/IP Offload Engine) interface card. A standard network interface card, can be used to connect and existing ESXi server to a remote iSCS…
    This Tutorial covers a very basic and common question asked on Experts Exchange, "How Do I Clone or Copy a virtual machine in VMware vSphere Hypervisor ESX/ESXi 4.x, ESXi 5.0?" Using the following method, no third party tools are required or need…
    Teach the user how to install vSphere Update Manager  Console to Windows system:  Install vSphere Update Manager: Configure vSphere Update Manager plug-in in vSphere Client: Verify vSphere Update Manager settings in vSphere Client:
    This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

    779 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    12 Experts available now in Live!

    Get 1:1 Help Now