Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1140
  • Last Modified:

Outlook Forward to Gmail not Working

I have resorted to having this go through GMail.  The phone reads the GMail account without any problem; however, now there are some issue with the Rules and Alerts to forward the email to Gmail. I have setup two different rules.

1. redirect email to xxx@gmail.com
2. Forward Exchange email to xxx@gmail.com

I cannot tell if it is doing anything with the redirect rule but I do know it isn't happening.  The forward rule is trying to happen.  The mail does appear in the sent items folder but Gmail is not recieving it.  I found a VBScript to use in the rules for Script but no matter where I save it, it doesn't show up on the script menu to choose from.

At this point, I just want to get this working properly.  So I am changing my question to Forwarding Outlook Exchange email to a Gmail account.  This is the script I am trying to use.  If someone knows where to save it, I will be eternally grateful:

Sub CustomMailMessageRule(Item As Outlook.MailItem)
   MsgBox "Mail message arrived: " & Item.Subject
End Sub

Sub CustomMeetingRequestRule(Item As Outlook.MeetingItem)
   MsgBox "Meeting request arrived: " & Item.Subject
End Sub
0
mcleeves
Asked:
mcleeves
  • 2
  • 2
1 Solution
 
chakkoCommented:
Does it need to be a script?

You can do this on the Exchange Server.  You need to create an Exchange Contact with the gmail address.  Then for the user/mailbox you want to forward the email you need to find the Delivery options and choose to forward mail to the account -> choose the gmail contact as the account.
Then there should be a checkbox to also deliver a copy of the email to local mailbox also.

0
 
mcleevesAuthor Commented:
I have been able to create a Mail Contact on the server.  This is the process I followed:
Exchange Management Console (2007)
Recipient Configuration > Mail Contact> xxxx@gmail.com
Recipient Configuration > Mailbox > Domain Username >properties
This is where I have stopped. I was unable to find anything that referred to Delivery Options.  Can you point me in the right direction?
Exchange-User-Properties.pdf
0
 
chakkoCommented:
Open the Exchange Management Console and go to Recipient Configuration and then mailboxes.  Select the user and open Properties.  Go to Mail Flow settings, Delivery Options Properties.
Use the check box for Forward To:
Select the gmail contact
and put the checkbox to also Deliver a message to the Exchange mailbox.
0
 
mcleevesAuthor Commented:
Your have ABSOLUTELY SAVED MY LIFE.  I wish I would have gone this route in the beginning.  
Thanks
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now