• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 783
  • Last Modified:

How do I get outlook anywhere to bypass the internal Exchange Server and connect to an external Exchange Server

I was running Exchange 2007, Server and AD 2003 and all my desktops were part of a domain and they ran win 2003 and Office 2003. I've since upgraded the domain client systems to Win7 and office 2010. And instead of using my Exchange server we have since outsourced our email to an external Exchange Email Service provider. The new provider uses Autodiscover for clients to connect to their Exchange server.

My problem is that: When I attempt to connect a client's oultook to the external provider's Exchange using autodiscover the client outlook continues to attempt to try and connect to the internal Exchange Server (I have already turned off Autodiscover for the internal Exchange Server) unless I disconnect the client desktop from the domain. When I disconnect the client system from the domain it finds the external provider's Exchange Server  just find.

Can anyone tell me how to keep my client system's membership to the domain so they can access all those resourced and also successfully bypass the internal exchange server (which we are not using anymore) but connect to the external provider's Exchange Server via autoscover?
0
rwrenfro
Asked:
rwrenfro
  • 3
  • 2
  • 2
1 Solution
 
Mohamed ElManakhlyInfrastructure Team LeaderCommented:
you have to repair the outlook profile in order to obtain the new settings .. from outlook profile go to email accounts and click repair
0
 
jonyeltonCommented:
You also need to delete the DNS settings for autoconfigure from your domain controllers.  Look here for all the different methods that Outlook goes through for autoconfigure.  Delete any settings that points towards your local mail server.

http://support.microsoft.com/kb/940881
0
 
rwrenfroAuthor Commented:
I've tried repair but it still does not connect to the external server. And when I go into the outlook configurations it still shows the name of the internal server as the mail server.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
Mohamed ElManakhlyInfrastructure Team LeaderCommented:
test your exchange autoconfiguration and let me know the results

Press Ctrl and right click on the outlook icon , from the menu choose "Test Email Autoconfiguration", type a sample username and password, only check "Autodiscover".
0
 
rwrenfroAuthor Commented:
I came up with a solution. Since the problem was that Autodiscover continued to point at my in house DNS Server.Once I confirmed I had correctly configured every TCP  and Autodiscover record in my DNS and all desktops were correctly made members of the domain. I set all the desktops to piont to our ISP DNS. This pointed autodiscover outside my network where it was able to see the autodiscover reference to the correct distination.

Thsnks Folks for all your comments.
0
 
jonyeltonCommented:
That's pretty close to what I told you........
0
 
rwrenfroAuthor Commented:
Hey jonyelton:

Sorry it took so long too get back to you. But I agree, you are absolutely right. While the key for me was being creative about the DNS source. I definitely did benifit from you input about clearing all DNS records pointing to my server. You earned the points Thanks A Lot. . .
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

  • 3
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now