W2K3 Terminal Server Not Accepting Connections

I have a Windows 2003 Terminal Server in Application mode.

It has been working correctly for about 3 years with no issues. Suddenly, this morning it is no longer accepting connections.

Things I have tried:

netstat -an: server is NOT listening on 3389
Terminal Services service: running
No firewall running on server (on same subnet)
Remote Desktop Users Group has all of the correct users in it.
No errors in event log that have to do with Terminal Services
I've check the registry entries and they all look correct.
Disabled virus protection - same result
Reset TCPIP stack - no help


One thing that has something to do with the issue, but I can't figure out exactly what:  
When I open the Terminal Services Configuration managment console and look at the properties of the connection ... if I click on the Network Adapter tab, the mmc hangs and has to be forcibly killed.   I deleted and recreated the connection, but the same thing happens.


This has the entire office down, so any help is GREATLY appreciated!!
robertbranchAsked:
Who is Participating?
 
robertbranchConnect With a Mentor Author Commented:
FYI here are the steps that were emailed to me from Microsoft support to clean the print hive:


Before we start with the print registry hive clean we should take the back up of the print hive.

Ø  To Back up the Print Registry do the Following:

·         Go to the following Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print

·         From the Registry Editor Menu Select: Registry\Export Registry File.

·         Save the the Print key as: Print_Bak or use a friendly name of your Choice.

Ø  Stop Spool Service from Services console


Lets continue now with the print registry hive clean.

Step 1:

Steps to Manually Remove 3rd Party Print Monitor

1) Start Registry Editor (Regedt32.exe) and locate the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors

Note: The default print monitors are:

=============================

· AppleTalk Printing Devices (When Services for Macintosh is installed)
· BJ Language Monitor
· Local Port
· PJL Language Monitor
· Standard TCP/IP Port
· USB Monitor
· Windows NT Fax Monitor
· LPR PORT <<<--- DO NOT DELETE

Except for the default print monitor, note down the name of the print monitor and their corresponding dll on the right side.

Example:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Monitors\hp laserjet 5
language monitor
Driver REG_SZ hpdcmon.dll

Note down the Monitor e.g.: hp laserjet 5 and hpdcmon.dll.

Do the same for all the print monitor except for the default one mentioned above.

2) Now, we need to go to the following registry and make sure we clear all printers from referencing Print Monitor/s except the default print monitor (mentioned above).

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Environments\Windows
NT x86\Drivers

· Version 2
· Version 3

Go over the entire Print Driver Version key and delete any references you may find

in the String Value named: "Monitors". Just click on "Monitors" to open the Editor and then delete the entry.

3) Repeat the previous steps under the Print Driver Version 3

4) Repeat the previous steps under:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Environments\Windows

NT x64\Drivers

· Version 2
· Version 3

5) Once done with, delete the print monitors except the default one mentioned above from the location:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors

6) By now, we have removed all 3rd party monitors and all print references to the

print monitors. Now, we need to make sure we rename the dlls used by the Print Monitors. In the above example, we are using the HP Laserjet 5 Language Monitor, however this could also be seen with other vendors.

To rename the dll we need to go to the following directory and search for the dlls that the Print Monitors were using.  In the example the dll that we have to search for is the hpdcmon.dll

** Renamed the dll to .old (Example: hpdcmon.old) You may find the dll under the
following directories:

%systemroot%\SYSTEM32·

%systemroot%\SYSTEM32\SPOOL\DRIVERS\W32X86\2 & 

%systemroot%\SYSTEM32\DRIVERS\W32X86\3

We have completed removing the 3rd party print monitor

7) Restart the Spool Service.


Step 2:

How to remove third party Print Processors:

Ø  Stop the spooler service first before proceeding.

Note the default print processor are:

Modi print
win print
ms_xps
 
1) Run the command to change the print processor to WinPrint.

wmic printer set PrintProcessor = "WinPrint"

2) Verify that the print processor entry have changed to WinPrint under the registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers

If any print processor is left unchanged then manually change it to WinPrint.

3) Now go to the location:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Print Processors

Note the name of the print processot and corresponding dll.

4) Delete all the print processor except the default print processor mentioned above.

5) Once deleted rename the dll to .old. You may find the dll under the
following directories:
 
%systemroot%\SYSTEM32·

%systemroot%\SYSTEM32\SPOOL\DRIVERS\W32X86\2 & 

%systemroot%\SYSTEM32\DRIVERS\W32X86\3

6) Restart the Spool Service again.

0
 
robertbranchAuthor Commented:
Just another piece of info:

No changes have been made to the server in the pasr 21 days.

0
 
PenguinNCommented:
Is your server service running and netlogon?
0
Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

 
robertbranchAuthor Commented:
Yes Server and Netlogon services are running.  I have restarted them to no vail and rebooted the server a couple of times with no change.
0
 
devinnoelCommented:
What errors/warnings are showing up in the Application & System log for the server?
0
 
PenguinNCommented:
How is your disk health, the hanging of your mmc sounds like a problem with your tcp/ip cable/files/other dependancy's. If you unplug the cable can you then open tcp/ip settings?
0
 
maxxmyerCommented:
@PenquinN good track, NIC card too.
0
 
robertbranchAuthor Commented:
I can open the NIC card setting, etc without issue.  It is only when I try to look at the Network Adapter tab in the Terminal Services Configuration that is hangs.

I'll check the issue with the cable unplugged and let you know.
0
 
devinnoelCommented:
Does anything show up in the event logs?
0
 
robertbranchAuthor Commented:
There are no errors showing up in the event logs about the terminal services.
0
 
PenguinNCommented:
Is your server patched to the last updates?
0
 
robertbranchAuthor Commented:
the Server has on Service Pack 1 becuase the vendor whose software runs on the server had not "certified" SP2.  I spoke with them and they agreed I could update to SP2, but when I attempt the install it starts and hangs at Inventorying Your Hardware and never proceeds.  It allows you to cacel the install, but the process never terminates.

Also, I sttempted to restart the NETLOGON and SERVER services. NETLOGON worked fine, but SERVER failed to restart.

I unplugged the NIC and attempted to look the Network Adapter tab in Terminal Services Configuration, but it still hangs.

Still no TS errors in the event logs.

I ran devcon.exe -r install %windir%\inf\machine.inf root\rdpdr ... it ran then rebooted the server and still no joy ....
0
 
robertbranchAuthor Commented:
Ok, the problem is solved.  I ended up bring Microsoft in to help resolve it.

The problem was a faulty print driver that had been installed that hung the print spool and ended up blocking all requests to port 3389.

We pruned the print hive, reset all of the print monitors to default and that resolved the issue.
0
 
robertbranchAuthor Commented:
I had to contact Microsoft Support in order to get this issue resolved, so I posted the solution for everyone to use.
0
 
Mad_LennyCommented:
Very many thanks for posting the solution Robert!! I stumbled across this eventually, just in time to save my bacon and make me look good :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.