[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3567
  • Last Modified:

SCCM Communication Settings block communication to DP

I am currently having problems deploying packages to my DP when using certain settings.
Packages can be deployed to the DP when only "Enable as a standard distribution point" is enabled, but as soon as I check the box for "Allow clients to transfer content from this distribution point using. BITS, HTTP, and HTTPS" everything stops working.  I need this option to allow us to distribute Virtual Applications.  
The two error messages I receive in the ConfigMgr Status Message Viewer are:

Failed to create virtual directory on the defined share or volume on distribution point "["Display=\\HSGSCCM1\"]MSWNET:["SMS_SITE=001"]\\HSGSCCM1\".

Possible cause: Distribution Manager requires that IIS base components be installed on the local SMS Site Server in order to create the virtual directory.  Distribution Manager also requires that IIS Web Services be installed on the Distribution Point Server that needs to support Background Intelligent Transfer Service (BITS).
Solution: Verify that IIS base components are installed on the local SMS Site Server, and IIS Web Services are installed on the Distribution Point Server.

AND

SMS Distribution Manager failed to process package "FireFoxTest" (package ID = 001000D3).

Possible cause: Distribution manager does not have access to either the package source directory or the distribution point.
Solution: Verify that distribution manager can access the package source directory/distribution point.

Possible cause: The package source directory contains files with long file names and the total length of the path exceeds the maximum length supported by the operating system.
Solution: Reduce the number of folders defined for the package, shorten the filename, or consider bundling the files using a compression utility.

Possible cause: There is not enough disk space available on the site server computer or the distribution point.
Solution: Verify that there is enough free disk space available on the site server computer and on the distribution point.

Possible cause: The package source directory contains files that might be in use by an active process.
Solution: Close any processes that maybe using files in the source directory.  If this failure persists, create an alternate copy of the source directory and update the package source to point to it.


Any help would be greatly appreciated.
0
dreedy
Asked:
dreedy
  • 3
  • 2
1 Solution
 
merowingerCommented:
normally this occurs if the IIS Roles "IIS 6 Metabase Compatibility"aund "IIS 6 WMI Compatibility" are not installed on the DP Server. Please do this via Server Manager
0
 
dreedyAuthor Commented:
I installed the IIS 6 WMI Compatibility, and the IIS 6 Metabase was already installed.  Same error occurs.
0
 
merowingerCommented:
Please check out the distmgr.log file.
Does the Site Server has Local Admin Permissons on the DP?
Is BITS installed?
WebDAV enabled and configured correctly?
0
 
dreedyAuthor Commented:
Thank you very much.  It turns out that I un-installed IIS on my DP, and forgot to re-configure my WebDAV rules.  After editing them, and restarting the server and reinstalling the DP service it worked.  Thanks again.
0
 
dreedyAuthor Commented:
WebDAV needed to be configured with the proper Authoring Rules.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now