Exchange 2007 growing log files

Hi guys,

Got a server running SBS 2008 where there is only 2.5GB mail but the exchange backup is 15GB. From what I can see, it's all the log files in the exchange folder. How do I get rid of them?
I'm using windows server backup and MozyPro (offsite backup).

Thanks
Talds_AloudsAsked:
Who is Participating?
 
RickEpnetConnect With a Mentor Commented:
When you backup with an exchange aware backup software it clears the logs.

You can setup circular logging this would take care of the log issue but you should understand the ramifications.
0
 
dmeerenCommented:
You can set a seperate directory for the log files in Exchange 2007, why don't run a batch file to delete them once a week or so?
0
 
Talds_AloudsAuthor Commented:
Well,
I suppose I'd like to know why they're not deleting themselves. And in addition to that, is it true you just can't delete any old log file? They have to be specific ones?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
ajpowell74Commented:
Is your backup set to backup "Everything"?
If it is, then it's taking the snapshot of your Exchange server, but isn't truncating the Exchange logs properly.

Try running a "Full" backup and not a "Copy". This will reset the archive bit, and should truncate the logs properly.
And please don't just delete Exchange log files. That will have an extremely messy ending for you.
0
 
Talds_AloudsAuthor Commented:
Yeah it's a full bare metal copy (windows server backup).
Offsite backup is just data and exchange component.

What do you mean do a full backup and not justa  copy?

Yeah don't worry - wasn't going to delete random log files.

thanks
0
 
ajpowell74Commented:
You can change it back to VSS copy backups by going to the advanced options tab and under the “VSS Backup Mode” setting, choose “Copy” instead of “Full”

In v5.1.1 and prior, the Exchange logs do not get truncated because BackupAssist was performing a VSS copy backup. So while your Exchange backups are definitely valid, it doesn’t appear that the backups are being performed because the logs weren’t being truncated.

They changed it in v5.1.2 and later that it will always perform a VSS full backup unless you specify otherwise. :)
0
 
RickEpnetCommented:
0
 
Talds_AloudsAuthor Commented:
Oh I think I see why this has been happening! Someone's been taking the backup HDD offsite and not bringing it back so we only have offsite backups occuring but not WSB still try to backup multiple times a day. I'll grab the drive and see if it fixes. Thanks
0
 
ajpowell74Commented:
That would definitely do it.

One thing to note:
Every time you change your backup location to a new drive, the SBS version of Server Backup will want to do a full backup as the first run.

You may have to let it run through the first backup, and then run another once that's done to see if your logs are truncating correctly.

Cheers.
0
 
Talds_AloudsAuthor Commented:
I suppose there were a few comments that answered this but this was the one that 'clicked' for me. After the first backup with the HDD back on site, 90% of the log files went. Thanks guys!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.